Skip to end of metadata
Go to start of metadata

Purpose

This wiki is going to cover the support of the SAP Java Virtual Machine (JVM) in SAP NetWeaver Application Server Java.

Overview

There are currently several different versions of the SAP JVM available to download from the SAP Service Marketplace. It can be confusing to understand which version of the SAP JVM you should use for your AS Java system. Below you will find out how to install or update the SAP JVM, as well as an overview of SAP JVM versions currently supported by AS Java.

Installation and Upgrading the SAP JVM in AS Java

The SAP JVM is automatically installed with AS Java releases 7.1 and above. For earlier releases the SAP JVM Switch Tool (SAP Note: 1555341) must be used to switch from a partner JDK.

It is required to use the Software Update Manager (SUM) tool to perform SAP JVM upgrades. SUM will also ensure that the correct JVM version is deployed to your system. For more information about SAP JVM deployments via SUM please review SAP Note: 1133020

SAP JVM Version compatibility in AS Java

SAP JVM 4.1 (JDK 1.4)

The following versions of the NetWeaver Application Server Java are compatible with the SAP JVM 4.1: 

  • SAP Web AS 640
  • Netweaver 04
  • Netweaver 7.0 EHP1
  • Netweaver 7.0 EHP2
  • Netweaver 7.0 EHP3

SAP JVM 5.1 (JDK 1.5)

The following versions of the NetWeaver Application Server Java are compatible with the SAP JVM 5.1:

  • Netweaver 7.1

SAP JVM 6.1 (JDK 1.6)

The following versions of the NetWeaver Application Server Java are compatible with the SAP JVM 6.1:

  • Netweaver 7.2 
  • Netweaver 7.30
  • Netweaver 7.31
  • Netweaver 7.40 

SAP JVM 8.1 (JDK 1.8)

  • Netweaver 7.50 

Related Content

SAP Product Availability Matrix

Related SAP Notes

SAP Note 1495160: SAP JVM as replacement for Partner JDKs 1.4.2

SAP Note 1555341: Downloading SAP JVM Switch Tool and SAPJVM 4

SAP Note 1133020: How to import a SAP JVM patch into an AS Java

  • No labels