Page tree
Skip to end of metadata
Go to start of metadata

This FAQ aims to answer the most commonly asked questions related to running SAP NetWeaver or SAP HANA based SAP products in combination with Red Hat products (Red Hat Enterprise Linux, Red Hat Virtualization, ...) and as appropriate refer to the relevant SAP Notes or other links/documentation. This is not an exhaustive list of all SAP/RHEL related topics. If your question is not (or only partially) answered here, please search for other SAP notes, SAP documents or contact the support representative.

FAQ Summary:

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Solution

1. Which SAP HANA DB releases are supported on RHEL?

For more information please refer to the SAP Note 2235581 - SAP HANA: Supported Operating Systems or https://wiki.scn.sap.com/wiki/x/SAe7Gg

2. Where can I find the list of all the technical documents on running SAP HANA DB on RHEL?

See Technical Resources for SAP HANA on Red Hat

3. How can I Install SAP HANA DB on Red Hat Enterprise Linux?

Refer to the SAP Note 2009879 - SAP HANA Guidelines for Red Hat Enterprise Linux (RHEL) Operating System. In attachment part of the SAP Note  you can find the required RHEL Configuration guides for SAP HANA.

4. How to configure optimal settings for running HANA on Red Hat Enterprise Linux?

You are running SAP HANA on Red Hat Enterprise Linux and you want to configure optimal Linux settings. According to different RHEL releases please refer to the following SAP Notes:
SAP Note 2292690 - SAP HANA DB: Recommended OS settings for RHEL7
SAP Note 2247020 - SAP HANA DB: Recommended OS settings for RHEL6.7
SAP Note 2136965 - SAP HANA DB: Recommended OS settings for RHEL6.6
SAP Note 2013638 - SAP HANA DB: Recommended OS settings for RHEL6.5

5. Which minimum version of RHEL is required for installing HANA 2.0 SPS 00?

For SAP HANA Platform 2.0 SPS 00 on Intel-based hardware platforms the minimum operating system versions is:

- Red Hat Enterprise Linux for SAP HANA (RHEL for SAP HANA) 7.2

For more information refer to the SAP Note 2380257 - SAP HANA Platform 2.0 SPS00 Release Note or http://global.sap.com/community/ebook/2014-09-02-hana-hardware/enEN/index.html

6. Which operating system software packages are required to run SAP HANA Database SPS11 revision 110 (or higher) on RHEL 6?

Refer to the SAP Note 2228351 - Linux: SAP HANA Database SPS 11 revision 110 (or higher) on RHEL 6 or SLES 11.

7. Which operating system software packages are required to run SAP HANA Database SPS08 revision 80 (or higher) on RHEL 6?

Refer to the SAP Note 2001528 - Linux: SAP HANA Database SPS 08, SPS 09 and SPS 10 on RHEL 6 or SLES 11.

8. How can I find the information about supporting the Automated SAP HANA Replication with Pacemmaker on RHEL?

Refer to the following link: https://access.redhat.com/articles/1466063

9. On which virtualization technologies is SAP HANA supported on Red Hat Enterprise Linux?

According to the SAP Note 1788665 - SAP HANA Support for virtualized / partitioned (multi-tenant) environments, KVM (on RHEL 7.x versions, supported for SAP HANA) with SAP HANA SPS 11 (or later releases) for non-production use cases. You can find more information about SAP HANA on KVM under the following Red Hat KnowledgeBase Article https://access.redhat.com/articles/2176051

10. How to subscribe RHEL 6 SAP HANA system to Extended Update Support (EUS) channel?

More information under "Red Hat KnowledgeBase Article" -> How to subscribe RHEL 6 SAP HANA system to Extended Update Support (EUS) channel.

11. How to subscribe RHEL 7 SAP HANA system to Extended Update Support (EUS) channel?

More information under "Red Hat KnowledgeBase Article" -> How to subscribe RHEL 7 SAP HANA system to Extended Update Support (EUS) channel.

12. On which RHEL release and platform is SAP NetWeaver based software certified?

For more information please refer to the following SAP Notes:

13. Where can I find the list of all the technical documents on running SAP Business Apps on RHEL?

See Technical Resources for SAP Business Applications on Red Hat

14. How can I find the information about supporting the HA SAP Netweaver-based Servers Using RHEL HA add-on with Pacemaker?

Refer to the following link: https://access.redhat.com/solutions/963123

15. Which virtualization technologies is supported to run the SAP NetWeaver on Red Hat Enterprise Linux?
16. What is included in the RHEL for SAP SKU?

Refer to the SAP Note 1631106 -  Red Hat Enterprise Linux for SAP Business Applications or Red Hat KnowledgeBase Article https://access.redhat.com/solutions/34169

17. What is "Red Hat Enterprise Linux for SAP Business Applications" Subscription?

You can find more information under the following Red Hat KnowledgeBase Article https://access.redhat.com/node/34169

18. What is “Red Hat Enterprise Linux for SAP HANA” Subscription?

You can find more information under the Red Hat KnowledgeBase Article https://access.redhat.com/articles/1187363

19. How can I run SAP products on RHEL on Amazon EC2?

SAP note 1618572 - Linux: Support Statement for RHEL on Amazon Web Services

20. How can I run SAP products on RHEL on Microsoft Azure?
SAP Note 1928533 - SAP Applications on Azure: Supported Products and Azure VM types
SAP Note 2316233 - SAP HANA on Microsoft Azure Large Instance Types
21. Upgrading from a previous Red Hat Enterprise Linux release to RHEL7? 

In-place upgrades from RHEL 6 to RHEL 7 is supported, however you must at least have RHEL 6.5 installed on the system you plan to upgrade to RHEL 7. Direct OS upgrades from RHEL 5 to RHEL 7 are not supported. Please see https://access.redhat.com/solutions/799813 for the list of supported use-cases for in-place upgrades to RHEL 7.

Before starting the upgrade please make sure that all SAP and DB instances running on the server have been updated to a level that is supported on RHEL 7 and that a working backup of the server exists.

All SAP and DB instances running on the server must be stopped, and all file systems belonging to the SAP installation (/usr/sap, /sapmnt, /<DB>) must be unmounted before starting the OS upgrade procedure to avoid damage to the SAP installation during the OS upgrade.

See https://access.redhat.com/site/solutions/637583 for detailed instructions on how to perform an in-place upgrade to RHEL7.

22. Why switch to Red Hat Enterprise Linux for SAP applications from regular Red Hat Enterprise Linux subscription?

To meet any SAP runtime compatibility library requirement for the installation of the latest SAP NetWeaver products or for the usage of latest SAP kernels, Red Hat is shipping the package compat-sap-c++ as a part of Red Hat Enterprise Linux for SAP Applications channel. To access this channel, Red Hat Enterprise Linux for SAP Applications subscription is required.

Red Hat Enterprise Linux 7: With RHEL 7, Red Hat ships compat-sap-c++-5 to meet GCC 5 runtime library requirements of future SAP NetWeaver releases. At this time of writing, compat-sap-c++-5 is only available for ppc64 BE and x86_64 architecture.
Red Hat Enterprise Linux 6: With RHEL 6, Red Hat ships compat-sap-c++ to meet GCC 4.8 runtime library and compat-sap-c++-5 to meet GCC 5 runtime library requirements of the newer SAP NetWeaver releases. Refer http://access.redhat.com/solutions/2670361 for more information. It is recommended to upgrade the base system to RHEL 6.8 prior installing the package. At this time of writing, compat-sap-c++-5 is only available for x86_64 architecture. compat-sap-c++(4.8) is available for x86_64, ppc64 and s390x architectures.