Registration

Dear SAP Community Member,
In order to fully benefit from what the SAP Community has to offer, please register at:
http://scn.sap.com
Thank you,
The SAP Community team.
Skip to end of metadata
Go to start of metadata

1) Solution Documentation Assistance (SoDocA) in SAP Solution Manager:

To support complex SAP Solutions and critical processes, it is absolute necessary to identify, map and document up-to-date information on System Landscape, Business Processes, Components, Interfaces, Custom Code and Partner Solutions. SAP is truly aware about this challenging task and therefore, delivered a tool within SAP Solution Manager called 'Solution Documentation Assistance' or in short 'SoDocA'. It enables SAP Customers to gather usage data of Business Processes, Objects, Components, Interfaces, Custom Code from SAP Solution landscape. It assists them in analyzing usage data for comprehensive documentation and defining blueprint for Implementation, Upgrade projects and setting up critical Business and Interface Monitoring.

2) Important Prerequisite Information:

1. In SAP Solution Manager all systems landscape information need to be up-to-date with successful RFC connections and running Early Watch Alerts for SoDocA analysis.
2.To gather usage history of your critical Business processes and other objects, SoDocA has to be setup well in advance. SoDocA requires minimum of one month data
3. A Project has to be created and the list of all the Business Scenarios, Processes and Process Steps have to be defined in the project.

3) Technical Prerequisites:

  • To Provide the necessary additional data for the Solution Documentation Assistant, SAP enhanced the SAP  software component ST-PI.
  • Managed systems must have release 4.6C or higher.
  • A running Early Watch Alert service for a managed system is required to provide workload statistics data for the Solution Documentation Assistant to analyze.
  • Analysis is dependent on:
  • The workload statistic settings in each managed system that shall be analyzed with Solution

Documentation Assistant.

  • The availability of data for managed system that is collected and stored in the Solution Manager

determines the number of months that can be analyzed.

  • Early Watch Alert must deliver data a minimum of one month before the first analysis run starts.  The Solution Documentation Assistant takes into account data of a full month, meaning the latest month available for a current Analysis is the last month.
  • System Landscape information needs to be up-to-date for the manged systems, RFC connections need to be created and accessible. This is necessary for collection of EWAreports as well as for SQL statement analysis.

 

4) Roles and Authorization:

Below Roles must be given to the Solution Manager Consultant on the Managed System (Solution Manager).

  • SAP_ADA_ALL
  • SAP_SDA_DIS
  • SAP_SMWORK_BASIC
  • SAP_SMWORK_SDA
  • SAP_SOL_PROJ_ADMIN_ALL
  • (SAP_SMWORK_IMPL)

Go to the Transaction SU01 to check the above roles, pleas e see screen shot below.

Authorization to the below Object should be given on the Managed System for E.g. SAP ECC, CRM, SRM

1)      S_ADMI_FCD  with all the values.

BASIS team or Authorizations team will provide you the above.

5) Activation of Services:

Before you start running Solution Document Assistance please if the below services are activated

  • sap/bc/webdynpro/sap/AGS_RBE_AD
  • sap/bc/webdynpro/sap/AGS_RBE_AR
  • sap/bc/webdynpro/sap/AGSTWB_CE

 

 

6) RFC Connections:

Execute Tcodeè SMSY è Click Tab Landscape Components è Product Systems

Under Product Systems you need t o select your system on which you want to run the Analysis. For e.g. we are running Analysis on Idigo and the Product System  has to be selected under SAP ECC. See below screen shot.

Select the Client Name è Select the Client è Click on the RFC button on top of the pageè you will get screen below è Again click on the Check button.

Please see the screen below

The  display logs should have all green traffic lights.

Note: If you see Red Traffic light then you do not have access to the System you want to connect to run analysis, in this case please send an email to the BASIS team requesting access.

 

 

 

7) Assignment of Business Scenarios:

Selection of a Project

Execute Tcode è SOLAR01è Select the Project è Click  the Other Project button see screen below


Select the required Project from the displayed selection and press the tick mark

 

 

Selection of a Businesss Scenario:

 

Under Strucuture tab you can assign the required Business Scenarios.

To Assign a Business Scenario from a Standard BPR Press F4 for selction, see screen below.

Note:  At the Source Selection you need to select Business Process Repository for assigning from a Standard BPR on SOLAR01.

From the below Selection list you can select your required Business Scenarios

To Manually Create a Scenario:

Under the structure tab you can Enter the Scenario Name and SAVE. You can see the newly created scenario under the Business Scenarios Folder.

8) Creation of Business Processes:

When you assign a Business Scenario by selecting from the Standard BPR you will also have all the Business Processes which falls under that scenario.

We can Add or delete the Business Scenarios, Business Processes or Process Steps as per our requirement.

You can repeat the same process you have

You can also manually create a Business Process under the structure tab,  type your Busniess Process Name and SAVE you will see it under list of your Business Processes,see screen below

 

9) Creation of Business Process Steps:

Execute Tcode SOLAR01è Select the Required Business Process under which  you want to a new process step to be added, enter the Process step name and Assign the Logical Component and SAVE, you will see the newly created Process Step under the Business process,see screen below

Note: If you want to adda new  Business Scenario, Process or Process Step you need to run SOLAR01 transaction Select the project you want to add and Under Structure tab you can Assign the required from the Standard BPR or can manulay create them.

 

 

10) Assignment of Logical Components:

Once the Created Project Structure is ready with the list of all the Business Scenarios, Buniess Processes and process Steps you need to assign the Logical Component to the Project. See screen below

Executeè solar_project_admin  è Select the Project è Press the Tick mark       

Go to System Landscape tab è press F4 è Select the required Logical component from the displayed window è SAVE.

Assignment of Logical Components for Business Scenarios:

Once you finish assigning the Logical Component at the Project level you need to assign the Logical Component at the Business Process Level.

Go to SOLAR01 è Select the Project è Select Business Process è Under Strucutre tab è You can select Logical Component è SAVE.

 Repeat the same for all the Business Processes in the Project Structure.

Note: If there are transactions at the Business Process Level please ensure that the Logical Component is assigned to it. As it will not change when you assign at business process level.

Go to Transactions tab in the same window and change, see screen below

11) Creation of Analysis Project:

Go to Tcode solman_workcenter  è Click the Tab Solution Documentation Assistant



Below Screen dsiplays

Click on Create Analysis Project

Below Screen Displays

At Project ID* è Click the selection.

Below screen displays è Place the cursor at Project ID: è Click on Start Search Button

Below Screen displays è Select the Created Project.

For e.g. we want to select the Documentation Take – On Project for Indigo è Press OK



Below Screen displays with the Project ID and Description of the selected Project è click on Next

Below Screen displays è You can Name the Project as per your standards or can also keep the same as it is with the created project in SOLAR01. è Select the Ticx boxes as shown below è Click on Next

Below Screen displays è Check if the Business Processes are selected è Click on Create

Note:  we can also select and unselect the business processes at this step, if you click the expand button you can see the list of all the Business Processes and steps for the created Project.

Below Screen displays

You have successfully created an Analysis Project.






 

 

12) Create Analyses based on Analysis Project:

Go to Tcode solman_workcenter è Click Solution Documentation Assistant tab è Select the Created Analysis Project for e.g. we have selected Indigo_Analysis Project è Click on Create Under Analyses based on Analysis Project “Indigo_Analysis…

Below Screen dispalys

Enter the Name as per your standards è Select the Schedule Mode – Immediate è Click Next



Below Screen displays

You need to change the System Role to Production System, The Status should be green, after you change the system role.

Below Screen displays

Clcik on Next      

Note: The status should be green for us to move ahead to run the Analysis.This will only be green if the Early Watch Alert Reports are generated for a minimum of one months on the system you want to run analysis on.


Below Screen displays

Click Next

Note: The Analysis will be based on last three months from the date we are running.

Below Screen displays

Click Next


Below Screen displays

Select the below Parameters

To get all the Customer Objects Select the Tick box Get All Customer Objects è Task Type: ALL è Create

Below Screen displays

You have successfully  created Analyses based on Analysis Project for Indigo.

Go back to the Analysis Projects Window you will see the screen below, the status of Analyses will be Running. Wait till you see Finished

After it finishes Running you will see a Status Saving

Finally you will see the Result as Finished.

Your Analyses based on Analysis Project is Succesfully created.

13) Verifying Analysis Results:

Once You see the Status Finished è Click on the Created Analyses è New window will open

Below Screen displays

To view the Results

To View Results è Click on Used è All Used Transactions & Programs are displayed.

Repeat the same process to view the results for Not Used, Analyzed, Not Analyzed under threir respective areas ( All Transactions & Reports, SAP Transactions & Reports and Cutom Transactions & Reports).

Once you finish Analyzing the Results

a)      You can Update the existing project with the results or

b)      You can Create a new project with the results.






14) Updating the Project with the Results:

After you Click Update Solution Manager Project è Below screen displays è Update Actions as per your requirement è Click OK.

Once you Change the Update Actions and Click OK the below screen displays è Click Yes

The Project is updated as per the Actions you choose to Update.

Go to SOLAR01 è Choose your Project è See screen below

You have successfully update the Analyses results to the current Solution Manager Project. Now you can

expand the Business Scenarios, Business Processes and Process Steps to see what is in Scope and Not in Scope.

Note: You can also select the required Transaction or Program to put in Scope from the structure if you think it is necessary which will be confirmed by the business consultant or the respective person.

15) Documentation & Documentation Types:

In Solution Manager we have kinds of Documentation types available.

Doc. Type

Description

ACC

Accelerator

AD

Additional Documentation

BB

Business Blueprint

BPP

Business Process Procedure

CFG

Configuration Guide

COFG

Configuration Reference

ITT

iTutor Document

PCDO

Process documentatn

SDO

Scenario Documentation

SLD

Solution Design Documentation

SNO

SAP Note

ST

Test Note for Test Case

TD1

Test Case Description

TR

Training



We have two types of document tabs

1)      General Documentation tab

2)      Project Documentation tab

General Documentation:

All the documentation delivered by SAP is in the form of general documentation, which cannot be    changed by the customer. These documents take i.e. form of Scenario descriptions on Installation guides.

 

Working with General Documentation:

 

For template project types, the general Documentation tab provides the same functions of the Project Documentation tab. For Implementation projects , the General Documentation tab has limited functions to display, export and sort documents.

To copy general documents for further processing and use in project  documentation, you need  to click the Copy Documents to Project Documentation icon.

Note:  Any changes made to copied documents will not affect the original texts.

  • To Copy a document from the General Documentation to the Project Documentation tab:
  • Choose one or more documents by selecting the corresponding row(s).
  • Click the Copy Documents icon to Project Documentation icon.
  • Enter a documentation type for the document.
  • Click Copy to transfer your entries to the structure. The documents are copied to the Project Documentation tab, where you can access and edit them.

Project Documentation:

 

All the documents specific to the project can be assigned in the Project Documentation tab. You can create the new project docuemntation in this tab. For e.g., Functional Specification, Business Blueprint document etc.

Working with Project Documentation:

 

You can use the Project Documentation tab to ceate, add, display, or delete specific project documentation on individual structure items for the implementation project. You can also display the document attributes or export documents.

16) How to attach New Documents:

To Create a New Document

In Project Documentation Tab Select the Option  Create New Document .

Below Screen displays

In the Title Field enter the title name of the document and select the document type and choose enter.

Select the documentation type which is relevant for your project. More details on document types available in Solution Manager please refer point 15 of this document.


New Document is Created, See screen below

Once you created a New Document è Click on Save.

Process

You have successfully created a New Document under Project Documentation tab.

 

To Upload a document from a Local System:

To Upload a File from Local Drive Select Upload File Option è Change the Documenttation Type as Required è Change Status as required  è Click Continue.  









Below Screen displays

Link to a Solution Manager Document or Copy of a Solution Manger Document:

This Function is to add a document provides a  flexible search feature to locate an existing document in the Knowledge warehouse.

It is not possible to link to external documents (KW Constraint) unless they are accessible from an URL. It is recommended to check in those doscuments that you wish to link to the structure element.

Enter all the required attributes on the screen and click Save, see screen below

To Upload a Document using Web Link:

Enter the Title Name è Choose the Documentation Type è Choose the Status è Click Continue

17) Manage Document Versions in Solution Manager:

Project Documentation/Document Attributes:

Go to SOLAR01 èSelect a Business Scenario you want to Upload/Edit the document è  Select Project Documentation tab è Select Document

Displaying Document Details:

The History tab displays technical details such as who created or changed the document, when it was created, when it was last changed, and the original language of the document.

Displaying Document Versions:

Current and older document versions can be displayed via the history tab. Mark a respective line and select the Display icon to display the selected document version.

Note:

In addition to document versions Solman offers a change history on tabs (which can be deactivated in SOLAR_PROJECT_ADMIN) based Change Documents. And additionally you can compare a copy of any structure element in a project against it's original using the "Compare and Adjust" functionality on tabs. This is documented in Extended Help in Detail.

You can select the any version of the document here and click display. You can see the changes in the document since you have uploaded.

18) Creation of Business Blueprint:

After creating the Business Blueprint  ( project structure, project documentation and transaction assignments), you can generate the Business Blueprint document for approval and use.

The Business Blueprint Document typically reflects a consolidated big picture of all thework we have done in the blueprint phase and includes the defined process strcuture with documented business processes as well as their graphical representation. It also contains all other kinds of documentation. Such as functional requirements.

Procedure:

Go to SOLAR01 or Implementation and Upgrade Workcenter è Plan è Define Business Blueprint

Select Business Blueprint è Generate Business Blueprint è A selection screen with three tabs will pop up.

You can specify a shared repository or drrive for the generated blueprint document, under Directory, to make the blueprint document available to other project team members.









In the General tab, select the check- boxes beside which Graphics should be included in the Blueprint.

You can leave the default directory location for storing the document.

Flag which graphics to include in the generated document (Scenarios and or Business Processes) under the General Tab.


In the Scope tab specify what Structure Elements and Documents to consider in the Business Blueprint generation and decide how much you want to include in the Blueprint.










In the Display Options Tab which strucutre Elements and Document Attributes to include in the Business Blueprint can be selected.

In MS Word choose the menu Tools è Macro èView Macros. Then select the macro SAP_BUSINESS_BLUEPRINT from the list and choose run.

The Blueprint document will now appear.

 

 

Note:

Business Blueprint generation will download all relevant documents to your local hard disk first. Select critieria to minimize generation time.

Not all the documents linked in the Solution Manager will be embedded in the Blueprint Document.

Only those documents with the docu attribute “Business Blueprint relevant” set will be included in the Business Blueprint Document.

19) Creating a Configuration Guide:

  We can generate a Configuration Guideout of our Project. We can select which parts of the Structure and which document types with which status, person responsible and keywords should be included to the guide. Then the documents are downloaded to the specified directory. Afterwards you start

Procedure

Go to SOLAR02

Please refer point18 to repeat the steps for the displayed window with three tabs (General, Scope, Display Options).

Go to the path where you saved the Document and repeat the below step.

Microsoft Word go to View è Macros è View Macros è Run the SAP_CONFIGURATION_GUIDE

The Configuration Guide is successfully created.

 

20) Reporting:

We can save information about a project by phase or project activity, for example, status, deaadlines, and team members. Project analysis is based on this information.

The more details you record, the more project analysis options there are. You can analyze a project,  a project view  (only for customizing projects), or several projects simultaneously, based on the selected project type.

The Project analysis and analysis results display options are very flexible. You can use selection criteria to restrict the scope of the analysis.

You can use the following analyses in project analysis based on the selection criteria you chose:

Project Information: Status Information and documentation type analyses

Progress Monitoring:  For example, by linking various status information,  such as project team memebers and a given status, or by aggregating project information.

General analyses:  For example, daily analyses

Administration:  Analysis of administrative information structured by general status analysis and worklists, which can be assigned to one or more project members. In analysis by worklists,  you can focus the analysis on specific data such as the status planned end.

Assignments:  Analysis of assignments in the project structure, i.e. documentation, transactions or issues/messages that we added during the project.

 

21) Move Project Into Solution:

Go to Solar_project_admin è Select as Template Project è Click on Save

Create an Implementation project based on SAP implementation content stored in the Business Process Repository (BPR) or with your List of Business Processes and alternatively create and execute a template project with templates containing standardized business process e.g., for use in global rollouts. The template project may also be based on SAP pre-defined implementation content.

Implemet the Solution in the Implementation project .

Transfer the implemented solution into a productive solution by copying the project content into the solution.

Perform ongoing changes/corrections to the solution in a maintenance project (ideally using check-in/out  functionality)

Procedure:

Go to Tcode dswp è Select Landscape è Select Solution Landscape è Solution Settings

Selecting  Landscape è Double Click the Landscape  è from the next screen select Solution landscape

Below Screen displays è Click on Solution Settings


Below Screen is displayed

Select the Landscape è Expand è Select Business Scenarios è Under Structure tab èChange Source from where you want to copy è Select Coloumn and Press F4

Below Screen displays after your selection

Select the Project è Expand the Business Scenarios è Click Copy

You have successfully moved your Project into Solution.

  • No labels