Skip to end of metadata
Go to start of metadata

Purpose

In some cases it is necessary to replace the JCo of ECTR with a current version. This replacement can be done either by installing a current version of ECTR or by manually replacing the JCO libraries. Since JCo is usually downward compatible, an exchange with a higher version is possible without problems.

Overview

This explains the manual exchange of the JCo libraries. 

Check the currently used version

Open the console logfile from logfile directory. Search for this line:

JCO version: 3.0.20 (2019-09-05)

Download the current available version

You can find the latest version here. Download the latest "Microsoft Windows and Windows Server" - "64-bit x86*" file for the appropriate revision level

For ECTR older then 5.1.16 / 5.2.2.1 use JCO 3.0.x. JCo 3.1 is not compatible with 5.1.15.3 and older.


Replace libraries


  • Replace sapjco3.dll + sapjco3.pdb in directory <ECTR>\basis\sys\win\lib64.

If you're running the 5.1 installation on a 32 bit platform (quite unlikely), you need also to replace the lib32 dll and pdb. 

  • Replace sapjco3.jar in directory <ECTR>\basis\libraries.


Related Content

Related Documents

https://support.sap.com/en/product/connectors/jco.html


Related SAP Notes/KBAs

2233626 - ECTR: SAP Engineering Control Center 5.1 FRONT - Patches

2779488 - ECTR: SAP Engineering Control Center 5.2 FRONT - Patches



  • No labels