Registration

Dear SAP Community Member,
In order to fully benefit from what the SAP Community has to offer, please register at:
http://scn.sap.com
Thank you,
The SAP Community team.
Skip to end of metadata
Go to start of metadata

 

Short demo video Demo on Using Plateau Report Designer 

PRD User guide Getting Started with Plateau Report Designer.pdf

Plateau Report Designer Installer Download

Installing SF Learning Report Designer (a.k.a. Plateau Report Designer)

  1. Download the SF Learning Report Designer installer provided above. 
  2. When prompted by the installer, change the install path to My Documents (do not install Report Designer into the Program Files folder) 
  3. Run Report Designer under Start Menu -> Plateau Report Designer -> Plateau Report Designer 
  4. We recommend moving the Report Designer panels to match the following screen shot. Add a panel, such as Properties, under Window -> Show View

Note: You will always open and modify reports that are exported from SF Learning. We will not create new custom reports under File -> New.

Initial Report Designer Settings (Window -> Preferences)

Data Set Editor -> Set Number of rows to display to 10

 

Data Set Editor -> JDBC Data Set
- Uncheck Prefetch all Schemas from database
- Uncheck Enable SQL Code Assist
- Set Maximum Number of Schemas to display to 1
- Set The time out limit to 15

Preview -> Data
- Set Number of rows to display to 10

 

Creating Workspace Short-cut and Originals Folder

  1. Navigate to My Documents/Plateau Report Designer 
  2. Create a shortcut to the Workspace folder  
    1. Right click the Workspace folder  
    2. While holding down the right button, drag the folder to the Desktop  
    3. Select Create shortcuts here (do not move the folder)
  3. Double click the Workspace folder shortcut 
  4. Verify the folder path is under the My Documents/Plateau Report Designer/Workspace 
  5. Create a new folder called originals in the Workspace directory. This folder will be used to back up the zipped report files that are exported from SF Learning

Creating an ApplicationResources.properties File

  1. Log into to SF Learning. 
  2. Navigate to System Admin -> Tools -> Label Import/Export 
  3. Select Export Labels 
  4. Click Next
  5. Select Locale (Typically English) 
  6. Click Next 
  7. Click the add one or more from list link 
  8. Click Add/Remove Criteria arrow 
  9. Check Label Type ID 
  10. Click Submit Query 
  11. Enter LABEL into Label Type ID 
  12. Click Search 
  13. Check the Select all the labels of the search results check-box 
  14. Click Add (this may take a couple minutes) 
  15. Click Next 
  16. Enter PRD_Labels in the Export File text-box 
  17. Click Download 
  18. Move the text file to Report Designer Workspace 
  19. Rename the text document to ApplicationResources.properties

Updating a System Report in Report Designer

  1. Export Report from SF Learning. See list of Standard Reports in LMS or Most commonly used Standard report
  2. Move the zip file to the workspace 
  3. Unzip the report 
  4. Rename the .rptdesign file 
  5. Move the zip file to the originals folder 
  6. Open the .rptdesign file in Report Designer 
  7. Connect the DataSource to Database See Connecting with Plateau Report Designer 
  8. Preview the Report, scroll to the bottom, and check for errors 
  9. Make Changes
  10. Preview 
  11. Repeat steps 9 and 10 as necessary 
  12. Remove any filters in the Master Query 
  13. Preview/Save the report 
  14. Select the Report Name in the Outline Panel and click the Zip icon 
  15. Save the zip to the Workspace 
  16. Import the zipped report into SF Learning 
  17. Test the report in SF Learning Publishing an Admin Report 
  18. Add the Custom Report Workflow to desired Admin Role 
  19. Assign the Admin Role to desired Admins
  20. Click the(pencil icon) next to the Report, check Publish, and then click Save

 

Add a New Data Object to a Report

  1. Add a row or column for the new field
  2. Copy and paste a label into the new row/column
    1. Select the new label  
    2. Go to Properties Editor panel  
    3. Select Localization  
    4. Click the Browse… button to select a new label value
  3. Find the Table Data Set  
    1. Select the Table tab in bottom left corner of the Table  
    2. Go to Properties Editor and select the Binding Tab
    3. Make a note of the Table Data Set name
  4. Under the Data Explorer Panel double click the Table Data Set, found in step 3, to open the query
    1. Add the desired data object to the SQL
    2. Preview the SQL and check for Errors
    3. Click OK to save your changes
  5. Drag the new data object from the Data Explorer panel to the row/column that you created in Step 1
  6. Preview the Report

Joining Tables

  1. Find the table that has the desired column
  2. Look for this table in the original query FROM clause. If it is already in the query, skip to step 5
  3. Add the table to the FROM clause
  4. Join the table to the original query on the related column in the WHERE clause
  5. Select the desired column from the added table in the SELECT clause

Concatenating Fields

  1. Right click an empty cell
  2. Select Insert -> Data
  3. Enter a Column Binding Name and Display Name (e.g. UserName)
  4. Select a Data Type
  5. Click fx to open Expression Builder
  6. Select Available Data Sets under Categories
  7. Select the Data Set under Sub-Categories
  8. Double-click the fields and use + to concatenate (use double quotes for static text), e.g. dataSetRow["LNAME"] + ", " + dataSetRow["FNAME"]
  9. Click OK
  10. Click OK
  11. Preview the report

Translate Localized Fields

  1. Double click the localized field that you added to the report
  2. Click fx to open Expression Builder
  3. Paste the following code: reportContext.getMessage(dataSetRow["CPNT_DESC"], reportContext.getLocale())
  4. Change CPNT_DESC to the localized field column name
  5. Click OK twice to save your changes
  6. Preview the report
    Note: Localized fields are blank in the Report Designer Preview. They will populate when run in SF Learning.

Adding a Search Filter

  1. Find the desired Report Parameter in the Plateau Library
  2. Drag it into the Report Parameters under the Data Explorer Panel
  3. Open the Data Set(s) that you want to apply the filter
  4. Update the Plateau comment to include the new Report Parameter Note: Make sure the security line is the last line of the Plateau Comment.
  5. Save, Zip, and import into SF Learning
  6. Test the Search Filter in SF Learning Note: You can only test Search Filters in SF Learning

Updating the Library Image and Styles

Image

  1. Open the PlateauThemes.rptlibrary
  2. Click Master Page tab.
  3. Double Click Image
  4. Select a New Image
  5. Save the Library
  6. Upload and overwrite the Plateau Themes library in SF Learning

Background Colors

  1. Click the row with the background color
  2. Select Property Editor -> General
  3. Write down the style (e.g. TableSectionTitleColor)
  4. Open the PlateauThemes.rptlibrary
  5. Click Outline Tab
  6. Select Themes
  7. Select PlateuSytleSheet
  8. Under PlateauStyleSheet find the Style you wrote down in step 3
  9. Double-Click the Style
  10. Click Background
  11. Select a new color
  12. Save the Library
  13. Upload and overwrite the Plateau Themes library in SF Learning

Binding Child Query to the Parent Query

  1. In the Child Data Set Query set the question mark equal to the column binding (e.g. SCHD_ID = ?)
  2. In the Child Data Set define a parameter that represents the question mark
  3. Select the Child Query Table, Navigate to Properties Editor, Select Bindings, and click Data Set Parameter Binding button
  4. Select the column from the Parent Table to bind the parameter

 

 

 

 Link: http://wiki.scn.sap.com/wiki/x/LI7SFw

 

5 Comments

  1. Is "Plateau Report Designer 4.0.0" still the recommanded version? A lot of the reports are still over this version and 4.0.0 don't support them anymore. There is a work around to change the version number in the xml of the report, but I am not sure if this is smart =)

    What BIRT Version you would recommand to build Report for LMS?
    I use 4.4.2 at the moment.

    Driver Class in 4.0.0: de.simplicit.vjdbc.VirtualDriverBirtWrapper (v1.6)
    Dirver Class in 4.4.2: de.simplicit.vjdbc.VirtualDriverBirtWrapper

  2. The demo link is broken. Can anyone provide a link to the demo video?

  3. Former Member

    Link to Video is still broken

  4. Hi Chris & Niels,

    Sorry for the delay!  I'm looking to see if I can find the original video that was linked in this WIKI.  In the meantime, there is a fairly decent demo on youtube that I also found useful for getting started with PRD:

    PRD Demo Video

     

    1. Former Member

      Found the link to the original demo video from Jonathan Grandey, long-time member of the Report Designer training community.

      This should work: https://icontent.plateau.com/icontent/SuccessAcademy/RD/ReportDesignerDemo/index.htm

      I had also recorded several other videos specific to tasks such as editing the Certificate of Completion. I'll upload these to a server and provide the links soon.

      Cheers,

      Lane Davis-Coury, Retired LMS/Report Designer Instructor