Registration

Dear SAP Community Member,
In order to fully benefit from what the SAP Community has to offer, please register at:
http://scn.sap.com
Thank you,
The SAP Community team.
Skip to end of metadata
Go to start of metadata

Purpose

The main objective of this page is to explain the compatibility between SRM-MDM Catalog, MDM Java API, MDM Connector and MDM Server

Overview

The application SRM-MDM Catalog is built over SAP MDM platform. The MDM components it manly uses are the MDM Server, MDM Java API and MDM Connector. The compatibility of these applications is informed in the SRM-MDM Release Notes.

This document will present how to check the versions of each of these applications and it will also explain how to fix the compatibility in case there is a version mismatch.

Checking the compatibility of your applications

You can verify the version of the installed components either in the Connection Test tool or in the NW Server Component Info page.

  • Connection Test:
  1. Open the SRM MDM utilities:
    http://<J2EE_SERVER>:<PORT>/webdynpro/dispatcher/sap.com/tc~mdm~srmcat~uiutil/Utilities
  2. Logon as a Utility user (usually a J2EE Administrator) and choose "Connection Test"
  3. Provide the host name or IP address of your MDM server and leave the Port number empty. Click on "Start Testing" button.
  4. The result should look like this:
  5. In the connection test, MDM Server and MDM Java API version format is <Version>.<SP>.<Patch> .
    Example:
    Version 7.1 (7.1.06.230 Win64) means "MDM Server 7.1 SP6 Patch 230".
  • Component Info:

If you are using NW7.01, you can get this information by accessing the J2EE component info page in http://<J2EE_SERVER>:<PORT>/sap/monitoring/ComponentInfo.

If you are using NW7.3 or later is used in your system, access the NetWeaver Administration page in http://<host>:<port>/nwa/, then in the "Search For" field search for "Component Info".

In the Component Info page you will find the installed versions for:

      • Catalog UI (SRM_MDM_CAT)
      • MDM Java API (MDM_JAVA_API)
      • MDM Connector (MDM_CONNECTOR)
  1. The format of the MDM components installed in NW Server is 1000.<Version>.0.<SP>.<Patch>

    Examples:

    MDM_JAVA_API 1000. 71 0.0. 14 .106.20150524211100 means "MDM Java API 7.1 SP14".

    MDM_CONNECTOR 1000. 71 0.700. 13 .0.20141203220558 means "MDM Connector 7.1 SP13".

  2. The Catalog UI component info follows the format below:
SRM-MDM Catalog UINetWeaver 7.0xNetWeaver 7.3 (and higher)
SRM-MDM Catalog 3.0 (3.0)1000. 3.0.17.2  .20151015191513
SRM-MDM Catalog 3.0  SP17  P2 for  NW 7.0

1000. 3.73.4.4  .201543542825
SRM-MDM Catalog 3.0  SP4  P4 for  NW 7.3

SRM-MDM Catalog 7.0 EHP1 (7.01)1000. 7.0 1.12.3  .20150120220423
SRM-MDM Catalog 7.0 EHP 1  SP12  P3 for  NW 7.0
1000. 7.3 1.4.7 .20151210041812
SRM-MDM Catalog 7.0 EHP 1  SP4  P7 for  NW 7.3
SRM-MDM Catalog 7.0 EHP2 (7.02)

1000. 7.0 2.12.6  .20150427061748
SRM-MDM Catalog 7.0 EHP 2  SP12  P6 for  NW 7.0

1000. 7.3 2.6.18  .20150804081021
SRM-MDM Catalog 7.0 EHP 2 SP6 P18 for NW 7.3

Which are the corresponding releases? 

SAP KBA 2478855 - Dependency of NetWeaver, MDM Server and SRM-MDM Catalog UI - Guided Answer helps to find out the corresponding versions and provide the relevant release note.

Important:    As per SAP MDM maintenance strategy, the MDM supports SP(n-4) – SP(n), where n – latest SP available on the SMP. Based on this, the current supported MDM SP versions are: SP16, SP17, SP18, SP19 and SP20. 

For reference, please check the following SAP Note and it’s attachment: 2609142 - Maintenance strategy for SAP NetWeaver MDM 7.1

[SP 15 is included in the table below because the last patch based on NW 7.0x has been released for MDM SP15]

SAP MDMNetWeaver 7.0x

NetWeaver 7.3 / 7.4 / 7.5

 SRM-MDM 3.0SRM-MDM 7.0 EHP1SRM-MDM 7.0 EHP2SRM-MDM 3.0SRM-MDM 7.0 EHP1SRM-MDM 7.0 EHP2
7.1 SP20
7.1 SP19SP4 P20 - SP4 P21SP4 P12 - SP4 P13SP6 P32 - SP6 P35
7.1 SP18SP4 P17 - SP4 P18SP4 P11SP6 P29 - SP6 P30
7.1 SP17 

SP4 P12 - SP4 P15

SP6 P23 - SP6 P27
7.1 SP16SP13 P01

SP4 P7
SP4 P8 - SP4 P11 (4)

SP4 P8 - SP4 P9
SP6 P22
SAP MDMNetWeaver 7.0xNetWeaver 7.3 / 7.4 (1)
 SRM-MDM 3.0SRM-MDM 7.0 EHP1SRM-MDM 7.0 EHP2SRM-MDM 3.0SRM-MDM 7.0 EHP1SRM-MDM 7.0 EHP2
7.1 SP15 

SP17 P2 - SP17 P4 (3)

SP13 P0  (3) SP12 P6 (3)SP4 P6 (3)

SP6 P20 - SP6 P21

 

Observations:

(1) All the SRM-MDM Catalog releases built for NetWeaver 7.3 may be installed in NetWeaver 7.4 and higher (except when noted). For more information, check the SAP note 2119166.
(2) Entries with "–" means that there is not a SRM-MDM Catalog released for this SAP MDM version.
(3) Read SAP Note 2373702 - Release Information Note of SRM-MDM Catalog all versions based on MDM 7.1 SP15 Build 7.1.15.132
(4) Supports NW7.4 and above

Solving the incompatibility of your applications

Cross the version information you obtained from Component Info and Connection test in the compatibility table above. In case you have a version mismatch you should update your applications accordingly. Possible actions would include:

  • Upgrade SAP MDM to the corresponding release of the Catalog UI
  • Upgrade the Catalog UI component to the corresponding release of SAP MDM
  • Upgrade both SAP MDM and Catalog UI to a higher, compatible release

Important:    All the installed MDM components should be in the same SP level. This includes the MDM Java API and MDM Connector installed in the NW server; the MDM Server and MDM Import Server; and the clients SAP MDM Console and SAP MDM Data Manager.

Maintaining MDM Java API and Connector in different SPs than MDM Server may lead to connection errors.

You can obtain all the installation files for SAP MDM and Catalog UI in the Software Downloads section of SAP One Support Launchpad.

Related Content

Related Documents

SAP SCN Wiki Page - Maintenance Tools: Maintenance Planner and Maintenance Optimizer

Related SAP Notes/KBAs

SAP KBA 1650896 - SRM-MDM “Login Failed” error

SAP Note 1476694 - Change in SRM-MDM Catalog 3.0 components in SMP

SAP KBA 2160815 - FAQ Note: SRM-MDM Catalog versioning and compatibility with SAP MDM and SAP SRM 

SAP Note 2119166 - Support of SRM-MDM Catalogs for Netweaver 7.4 

SAP Note 2373702 - Release Information Note of SRM-MDM Catalog all versions based on MDM 7.1 SP15 Build 7.1.15.132

SAP Note 2422067 - Release Information Note of SRM-MDM Catalog 7.32 SP06 Patch 22 (NW 7.3/NW7.4/NW7.5)

SAP Note 2379538 - Release Information Note of SRM-MDM Catalog 7.31 SP04 Patch 8 (NW 7.3/ NW 7.4/ NW 7.5)

SAP KBA 2478855 - Dependency of NetWeaver, MDM Server and SRM-MDM Catalog UI - Guided Answer

SAP Note 2609142 - Maintenance strategy for SAP NetWeaver MDM 7.1