Skip to end of metadata
Go to start of metadata

Purpose

The perl module for ASE was created in SDK 15.7 base as a new feature. This module is built with a specific version of perl so only use that version.

Overview

Please also note that depending on operating system the bit support can be different. Please also note that different version for different versions of the SDK


Operating System Support:

PlatformSupported ModeExtension/ValuePerl Version Support
Linux64-bit threaded_64rPerl 5.14, 5.24,5.28
HP-UX32-bit non-threaded_32Perl 5.14, 5.24, 5.28
Linux on Power32-bit threaded_32rPerl 5.14, 5.24, 5.28
IBM AIX32-bit threaded_32rPerl 5.14, 5.24, 5.28
Solaris on SPARC32-bit non-threaded_32Perl 5.14, 5.24, 5.28
Solaris on x86_6432-bit non-threaded_32Perl 5.14, 5.24, 5.28
Windows 6464-bit_64Perl 5.14, 5.24, 5.26


Version Support:

  • Perl 5.14 and 5.14.1 and DBI version 1.616
    • Supported with SDK 15.7 for SAP ASE (Sybase Software Developer Kit)   15.7 GA for Unix and higher
    • Supported with SDK 15.7 ESD#1 for SAP ASE (Sybase Software Developer Kit ) for Windows and higher
  • Perl 5.24
    • Supported with SDK for SAP ASE 16.0 SP03 for Unix
    • Supported with SDK 16.0 SP02 PL00 for Unix
    • Supported with SDK for SAP ASE 16.0 SP03 PL02 for Windows
    • Supported with SDK for SAP ASE 16.0 SP02 PL07 for Windows
  • Perl 5.26
    • Supported in SDK for SAP ASE 16.0 SP03 PL07 for Windows
    • Supported in SDK for SAP ASE 16.0 SP02 PL09 for Windows
  • Perl 5.28
    • Supported in SDK for SAP ASE 16.0 SP03 PL07 for Unix

Related Documents

Related SAP Notes/KBAs

  • KBA 2153912 - ASE Perl Driver: Cant locate DBI.pm in @INC after running perl samples - SDK for SAP ASE
  • KBA 2292752 - Rebuild Perl module to use with newer Perl versions - SDK for SAP ASE
  • KBA 2295217 - Perl fails to load SybaseASE.so because it cannot find libsybct.so - SDK for SAP ASE
  • KBA 2367843 - Perl module errors with buffer overflow detected - SDK for SAP ASE
  • KBA 2436874 - SDK Perl module support for Perl version 5.24 - SDK for SAP ASE
  • No labels