Skip to end of metadata
Go to start of metadata

Welcome to the Documentation and Help Area of

Introscope

CA APM Introscope(R) is an application performance management solution created to manage Java Application performance. Unlike development tools, Introscope(R) is designed to scale with minimal performance impact. This allows you to monitor and manage your application performance in live production environments.
The Right to View (RTV) version of CA APM Introscope is a restricted, read-only form of the full product and is bundled with SAP Solution Manager. With the RTV version, support is limited to products that are licensed and supported by SAP. The instrumentation, dashboards, Probe Builder Directives (PBDs), management modules, and Smartstor data contained within the RTV version of CA APM Introscope as provided by SAP is the intellectual property of SAP. Use of these functions is restricted by SAP and may only be used in an unrestricted manner by licensing SAP Extended Diagnostics by CA, foundation from SAP.

Note: The product SAP Extended Diagnostics by CA, foundation is no longer on SAP price list. But you still can get the equivalent package from CA Broadcom directly.



Scope

  • Monitoring of non-ABAP applications and infrastructures
  • Tracing of non-ABAP applications and infrastructures

 

Benefits





Documentation


Contact
 
Technical Support

Open a Ticket for Component:
XX-PART-WILY

This page is part of the Application Operations Wiki. Notice that Application Operations itself is a use-case of SAP Solution Manager

 

  • No labels

7 Comments

  1. wily introscope did not run on Solman-7.2. on Linux-on-Power ?

    1. This depends on the Introscope version. The current version (10.5) does not run on PowerLinux.

      1. ThankU Cristian

        Christoph, check this note:

        2534316 - Introscope 10.5 Release Notes for changes and open issues
        4. Platform dependency of EM
        CA introduced a platform dependency that cause the EM to fail on startup similar to "[ERROR] [main] [Manager] The EM failed to start. /tmp/librocksdbjni7414627144441912552.so " if the platform is not supported by CA (e.g. "Linux on Power 64bit"). This dependency got discovered after SAP setup guide was published which erroneously still lists "Linux on Power 64bit".

         

         


  2. Hi Cristoph,

    following the PAM SOLMAN 7.2 supports OS LINUX ON POWER BIG ENDIAN and LINUX ON POWER LITTLE ENDIAN

    Check that the Introscope processes are running by using the following command:
    From the folder 
    <EM HOME>/bin
    run the command: ./EMCtrl.sh status

    Also, check this links:

    Monitoring & Alerting Infrastructure (MAI)

    https://ga.support.sap.com/dtp/viewer/index.html#/tree/381/actions/3797

    https://launchpad.support.sap.com/#/products/01200615320900006067

    SAP Notes:

    Check the required JVM version for your CA Introscope Enterprise Manager

    2285189 Introscope 10.1 Release Notes for changes and open issues

    1845926 - CA Wily Introscope Enterprise Manager does not start "Failed to bind to server socket"

    1630229 - CA Introscope Enterprise Manager has JAVA heap problems

    2170650 - CA Introscope Enterprise Manager stops with a Java core dump

     

    And try to install the latest Introscope patches: Introscope Enterprise Manager 10.5 for SAP SP02

    Introscope 10.5 is supported starting from the following Solution Manager support packages:

    • Solution Manager 7.2 SP06


    Regards

  3. I'm on windows 2016 server, just upgraded my SOLMAN 7.2 from SPS5 to SPS9. I currently run WILI 10.1.0.15. I started to look into upgrading to WILY 10.5 until I came across this oss#2534316 and the following statement:


    Known Problems

    1. EM installer fails on Windows Server 2016 / 2019

    Windows Server 2016 respectively 2019 is not supported for the Enterprise Manager installer of version 10.5.x. Installation actually fails with an error message like

    Flexeraax2$aaa: C:\usr\sap\SOL\tmp\I1519871422\Windows_Pure_64_Bit\resource\iawin32.dll not found                 at Flexeraax2.af(Unknown Source)                 at Flexeraax2.aa(Unknown Source)

                    at com.zerog.ia.installer.LifeCycleManager.init(Unknown Source)                 at com.zerog.ia.installer.LifeCycleManager.executeApplication(Unknown Source)                 at com.zerog.ia.installer.Main.main(Unknown Source)                 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)                 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)                 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)                 at java.lang.reflect.Method.invoke(Method.java:498)                 at com.zerog.lax.LAX.launch(Unknown Source)                 at com.zerog.lax.LAX.main(Unknown Source)

    Since there is no known technical problem running the Enterprise Manager on Windows Server 2016 / 2019  you can use the following workaround for installation:

    You must use JRE 1.8 u45 (JDK does not work) or previous version to launch the installer. For example: Launch the installer as below, this allows the installer to use 1.8u45 instead of the JRE bundled with the installer.

    introscope10.5.2.91windowsAMD64.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"



    My Question, can I Just stay on 10.1 with Solman 7.2 sps09?

  4. Hi Joshua,

    there is no known technical problem continuing with 10.1 and Solution Manager 7.2 SP9. But the 10.1 release will run out of maintenance at the end of this year and will not receive any additional updates. Thus it is advisable to move on to the 10.5 release. If you are hesitating to install an old JRE: download an early SAP JVM 8.1 patchlevel from SAP's software download center (I think I used PL3 last time) and just unzip it for the installation. You can delete it afterwards without any "traces".

    regards, Jens

  5. OK I got no problem, I simply installed the old java. My command was the following if anyone comes across this question

    introscope10.5.2.113windowsAMD64SAP.exe LAX_VM "C:\Program Files\Java\jre1.8.0_45\bin\java.exe"