Registration

Dear SAP Community Member,
In order to fully benefit from what the SAP Community has to offer, please register at:
http://scn.sap.com
Thank you,
The SAP Community team.
Skip to end of metadata
Go to start of metadata
The goal of this page is to collect all browser related information for Web Dynpro ABAP. For Internet Explorer document modes (Standards, QUIRKS) please see this page for more information.

Please always remember that the reference information for the browser support is the Product Availability Matrix.

You can check the supported browsers for your NW version in Product Availability Matrix (PAM). Please read and watch video in KBA 2152783 on how to check the supported versions.

Unified Rendering

When checking browser supportability please also make sure to check your Unified Rendering Framework (UR). In many cases the issues may be caused by the outdated Unified Rendering Framework. To see which is the newest UR version please visit Unified Rendering Notes - Which one to apply.

Overview

The list of supported browsers depend on your NetWeaver release and its Support Package (SP) level.
Web Dynpro ABAP is only supported with a standalone browser. All scenarios where the browser is embedded into another external product (e.g. using COM interface etc.) are not supported. Generally, Web Dynpro is not supported on smartphones, tablets, devices with integrated sensors on the fronted (like scanner, camera, RFID reader, GPS receiver, etc). Exceptions are discussed below.

Supported browsers at one glance

 

IE11
(Win 7)

 IE11
(Win 10)
MS Edge Firefox Chrome

Apple Safari 9.0/
Mac OS 10.11

Apple Safari on 10/
Mac OS 10.12

SAP Basis 700

SP29

 SP32(error) SP32(error) (error)(error)

SAP Basis 701

SP14

 SP17(error) SP17(error)(error) (error)
SAP Basis 702SP14 SP17(error) SP17 SP17SP17SP18

SAP Basis 730

SP10

 SP14(error) SP13SP14 SP14 SP16

SAP Basis 731

SP09

 SP17(error) SP16 SP17SP14 SP16

SAP_UI 7.40 (warning)

SP04

 SP11SP17SP11 SP11 SP11 SP16 
SAP_UI 7.50

(tick)

(tick)SP04(tick)(tick)(tick) SP06
SAP_UI 7.51(tick)(tick)(tick)(tick)(tick)(tick)(tick)
SAP_UI 7.52(tick)(tick)(tick)(tick)(tick)(tick)(tick)
SAP_UI 7.53(tick)(tick)(tick)(tick)(tick)(tick)(tick)

(warning)  SAP_UI 740 in SAP NetWeaver has reached the end of mainstream maintenance at the end of 2017.

References to supported browsers:

Microsoft Internet Explorer

SAP supports Microsoft Internet Explorer browser (IE) release cycle. Please use the latest IE security patch release.

Please note, that from January 12, 2016 only IE11 and newer releases will be supported by Microsoft. You can read more about it on IEblog. For technical reasons the 64-bit version is not supported. IE10 and higher versions offers several improvements in html5 and is the recommended browser if newer WD Objects are used. For Internet Explorer document modes (Standards, QUIRKS) please see this page for more information.
 
  

Overview of supported IE versions (no support for IE10 and below):

 

IE11

MS Edge

SAP Basis 700

SP29 (warning)

(error)

SAP Basis 701

SP14

(error)
SAP Basis 702SP14(error)

SAP Basis 730

SP10

(error)

SAP Basis 731

SP09

(error)

SAP_UI 7.40

SP04

SP17
SAP_UI 7.50

(tick)

SP04
SAP_UI 7.51(tick)(tick)
SAP_UI 7.52(tick)(tick)
SAP_UI 7.53(tick)(tick)

 (warning)  If the SP is high enough in NW7.00, but still getting 'browser not supported' error, check Note 1896793

(info)  See notes for more information: 228041222833161672817

 

Internet Explorer 11

  • IE11 Modern UI is not supported in general.  
  • IE11 introduced a new Enterprise Mode which is not supported.
  • IE11 has several performance issue, see more in SAP notes 2099080 and 2163772

  • Additional performance issue after installing KB3038314, see SAP Note: 2170160

  • End of Quirks Mode Support with SAP_UI 752 SP00, see SAP Note 1672817

  • When an application is started in Quirks mode in SAP_UI 752, CX_UR_NOT_SUPPORTED_DEVICE dump is raised, see KBA 2280412 

Mozilla Firefox

Mozilla Firefox is supported from NW 7.00 on. Firefox is not supported in NW 7.10.

Mozilla Firefox offers two versions:

Here is the release schedule for the next one year: 

SAP supports Mozilla Firefox Extended Support Release Cycle.


SAP provides conditional support for the Mozilla Rapid Release policy, due to the fast release cycle and the limited roll-back capabilities (previous version is unsupported).

(warning)  Restrictions for Mozilla Firefox

  • SAP Interactive Forms by Adobe are not supported.
  • Bidirectional text ("right-to-left") is not supported.
  • Accessibility is not supported including the following features:
    • Hotkey support
    • Access key support
    • Keyboard navigation support.
  • Firefox does not support ActiveX based plugins, like:
    • Crystal Reports,
    • Generic Active Component
    • Integrated Office Suite
    • MS Projects
  • Applet-based Integration is not supported.

More information can be found in SAP Note 990034 - Browser: Support Policy for Mozilla Firefox Browsers.

Google Chrome

Chrome is generally supported from SAP Basis 702. Using Chrome with lower SAP Basis versions is still tolerated but it is not supported.
SAP follows the Chrome release cycle, that means SAP Supports only those releases that are currently supported by Google.

Unified Rendering based applications have performance issues with Google Chrome version 56.0.2924.76.

More details can be found in SAP Note 2422288 - Chrome Issue: Performance decrease of Unified Rendering / Lightspeed based applications after upgrade to Chrome version 56.-


  (warning)  Restrictions for Google Chrome

  • Bidirectional text ("right-to-left") is not supported.
  • Accessibility is not supported including the following features:
    • Hotkey support
    • Access key support
    • Keyboard navigation support.
  • Chrome does not support ActiveX based plugins, like:
    • Crystal Reports,
    • Generic Active Component
    • Integrated Office Suite
    • MS Projects
  • From Chrome 45 onwards , the Silverlight and Java support will completely stop on Chrome. All the application which are using Silverlight and Java will not be able to run in Chrome browser at all. There has been no workaround provided by Google

More information can  be found in SAP Note 1655306 - Google Chrome for end users and administrators.

Apple Safari

SAP supports Safari Web browser for Mac OS. SAP doesn't support the use of the Safari browser on Windows.
Safari is generally supported only from SAP Basis 702. Overview of supported Safari versions:

 

Apple Safari 9.0/
Mac OS 10.11

Apple Safari on 10/
Mac OS 10.12

SAP Basis 700

(error)(error)

SAP Basis 701

(error) (error)
SAP Basis 702SP17SP18

SAP Basis 730

SP14 SP16

SAP Basis 731

SP14 SP16

SAP_UI 7.40

SP11 SP16 
SAP_UI 7.50 (tick) SP06
SAP_UI 7.51 (tick) (tick)
SAP_UI 7.52 (tick) (tick)
SAP_UI 7.53 (tick) (tick)

  • More information can be found in SAP Note 1634749 - Safari browser for end user and administrators

Mobile Devices

Read the below SAP Notes for information on mobile support in WDA

  • SAP Note 1853087 - Conditional support for browser usage on Mobile Devices
  • SAP Note 2700517 - Mobile device support for Unified Rendering based frameworks: Web Dynpro ABAP and SAP GUI for HTML

Related SAP Notes/KBAs

KBA 2152783 - How to check Browser Compatibility information for SAP NetWeaver

Note 1098009 - Web Dynpro ABAP - List of known Restrictions and Browser Support

Note 1853087 - Conditional support for browser usage on Mobile Devices

Note 1918612 - SAP IFbA: Information Reader/Browser support