Skip to end of metadata
Go to start of metadata

Purpose

This page describes the Unified Rendring Update process with TCI.

SAP Note Transport-Based Correction Instructions (TCI) is a new technology used to deliver ABAP correction instructions in a flexible manner. 

TCI validity:

NW ReleaseSoftware ComponentMINIMUM Support Package level
(to be able to use TCI)
NW700SAP_BASIS32
NW701SAP_BASIS17
NW702SAP_BASIS17
NW731SAP_BASIS6
NW740SAP_UI

End of mainstream maintenance

See: SAP Note 2583882

NW750SAP_UI4
NW751SAP_UI0
NW752SAP_UI0
NW753SAP_UI0

 Please find further information about the update process in the following notes:

2187425 - Information about SAP Note Transport based Correction Instructions (TCI)

 

Rollback

From UR patch 1710 it is possible to rollback TCI packages. However, this feature is reserved for emergency situations only. Due to cross technology compatibility, we DO NOT recommend to rollback TCI UR patches.

The attached PDF in SAP Note 2187425 contains detailed information and prerequisites of this feature. Please read and follow the steps carefully.

ATTENTION: 

In case there are syntax errors after TCI 1903 is applied, implement SAP Note 2776217.
This is only valid in case of TCI 1903.

About the TCI procedure

Before you start the process:

  1. If the system's  SAP_UI or SAP_BASIS version is below the mentioned minimum SP level. Please apply the newest Service Pack first, and proceed with step 2.

  2. Check that your user has one of the following authorizations:
      • SAP_OCS_STD (complete SPAM authorizations)
      • SAP_OCS_TCI_IMPORT (minimal SPAM authorization for TCI Import)

     

  3. Update your system's SNOTE version to the latest (see #875986 up to 702 and #1668882 for newer versions).

  4. Check that you have the option in tr. SNOTE -> GoTo -> Upload TCI in each system (development, quality and production), where the TCI update is planned. If this option is not available please open and follow the steps described in Note 2187425 .


The update process:

  1. Open the Main Unified Rendering Note 2090746 and open the TCI Correction Note which is valid for your NW Release.
  2. Check that your SPAM version is above the advised minimum level. (If not, please update it)
  3. Start /nSNOTE and Download TCI Correction Note
  4. In the TCI Correction Note Correction Instructions section click on the Software Components →  SAP_UI or SAP_BASIS, and download the corresponding TCI package. 
  5. Upload the correction package in SNOTE via GoTo -> Upload TCI.
  6. Implement the TCI Correction Note.
  7. Run SE38 WDG_MAINTAIN_UR_MIMES and click on Force Deployment.
  8. Check consistency. (In report WDG_MAINTAIN_UR_MIMES the two 'urchangelist' values have to be identical )


     

     

Video about the update process

2499004 - Unified Rendering update for Web Dynpro ABAP [VIDEO]

  • TCI is a cumulative patch, you have to install always the latest one.
  • The TCI Notes should be installed like normal notes in Dev or Production client.

  • The Objects are recorded in a Transport and can be transported like any other note correction.

 

FAQ

Why don't change the older UR TCI Correction notes to Obsolete or Cannot be implemented status?

These UR patches are commutative which means the newest TCI package contains every corrections which was delivered in previous TCIs.

Therefore every older TCI UR notes get automatically the "Completely Implemented" status. 

A note gets "Cannot be implemented" status when the prerequisites are not fulfilled. For example the SAP_UI service pack level is bellow or over the required. 

A note gets "Obsolete" status when a newer version is available or it was archived.

 

 


  • No labels

5 Comments

  1. Thanks for updating the wiki with the hint concerning TAs and Client 000 (wink)

  2. Hey there. We've been busy handling some UR-Problems in the last weeks and subsequently had to use the new TCI-based approach patching our Backend Systen and I'd just like to say THANK YOU! It's still a bit complicated to get the information you need for updating your system the right way, but the technical update process itself is so much smoother, it saves hours if not days of work and our servers' virtual Memory is very happy too! (smile)

    Again, thanks a lot and keep up the good work! (smile)

  3. Former Member

    I see that that TCI is supported only from SP06 for SAP_BASIS 731. We are on 731 SP05. How to we go about correcting this issue with Chrome? I also checked Update Unified Rendering via SAP Notes and it does not have 731 listed there. 

    1. Former Member

      Hi Ashwin,

       

      If your SP is below the mentioned minimum level, an SP upgarade is necessary. 

      SP 05 is really outdated in 2017.  Keeping the system on current SP is quite essential in the web-world (not only funcitonal but security-wise as well).

      Also please check the in the Product Availability Matrix the Browser support part. Chrome is supported on 731 from sap_basis sp17.

       

      Best regards,
      Andras

       

      1. Former Member

        Thanks Andras for the quick reply!! 

        We will take a look at the PAM for browser support as well.

         

        Thanks,

        Ashwin