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1 Introduction 
Animation in SAP 3D Visual Enterprise Author is based on keyframes. For example, the keyframe for an object in a 
simple move animation is simply a saved position for that object. Animation is the result of moving objects from 
one keyframe to the next. This is called tweening and stems from the word "between". 
A range of animation tools can be used to create new scene animations, and to modify animation within files 
imported from other applications system: 

 Animation supports object grouping, the display of motion paths, changing pivot points, and keyframes 

 You can create both a linear type animation where an object moves from one point to another like a pool 
ball bouncing off cushions, and a more fluid animation, where the object takes smoother corners. 
Animations can also be made cyclic; the entire animation is made to repeat from beginning to end. 

 You can render animated scenes to 2D illustrations as still images or a video clip, to multiple files, to raster 
or vector output including callouts. 

 When you save any file that contains animation, you should choose to export animation from within the 
export settings. 

 

This guide helps you to learn how to do the following: 

 Understand animation concepts such as tracks, keys, and timelines 

 Understand the importance of pivot points 

 Display and use the animation controls 

 View and edit keyframe animation 

 Create and edit animated sequences and steps 

 Create and edit procedures 

 Edit navigation and visibility 

 Establish animation settings 

 Duplicate, reverse, and delete steps 

 Edit tracks and keys 

 Create an exploded assembly animation 

 Save animated files 

 Render animated scenes to 2D images and to video 

 

Sequences 

A sequence is a collection of one or more animations of one or more objects. 

Steps and Procedures 

  Steps are a collection of animation sequences, that is, a ‘view’ of a scene that can store a starting 
position, object visibility, keyframe animations (sequences), and metadata. They allow you collect and 
manage animated sequences for effective playback and communication. 

 Steps can be rendered as raster or vector images or saved to video. 

 Steps can then be published to an HTML page, MS Office documents, and 3D PDF document. 

 You can ‘add value’ to steps after a complete assembly and disassembly procedure has been created, in 
a variety of ways including adding callouts, switching display mode, and adding ISO, tooling, and 3D 
symbols. We discuss these later in the training. 

 Procedures are used to organize a logical group of steps that can show myriad information such as how 
to assemble products, or to highlight marketing aspects of a product. For example, a series of steps can 
be created to portray the disassembly of a gearbox, and then the steps are published to a PDF document 
to create maintenance manual. 

 Procedures can be re-used as a template for new procedures or as a reverse procedure 

 Multiple procedures are supported by the .rh format. 
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Keys and Tracks 

A key is a value fixed in time - single value keys such as opacity, and vector keys such as position and color. Keys 
are located on their respective position, rotation, scale, or opacity track. They are created and edited using the 3D 
Editor toolbar or the timeline. 

Pivot Points 

As described earlier, the point around which each object rotates is called the pivot point. If you need to move the 
object’s pivot point, it is important to do so before creating the animation; moving pivot points after animation 
creation leads to irregular results. 
Often, the pivot point needs only to be moved when you are creating a rotation animation. You may only need to 
adjust the key pivot points of the parts that need animation, leaving all other pivot points as they are: 

 The most accurate way of moving a pivot point is by selecting the part you want to animate, and choosing 
the right-click viewport commands Tools > Move Pivot Point > Move Pivot Point to Object Center/to Scene 
Center/to Selection Center. 

 All object pivot points can be moved at the same time by selecting all objects, and choosing the right-click 
viewport command Tools > Move Pivot Point to Object Center. 

Animation Controls 

As seen in the previous section, the Animation controls are used to control scene animation. They include a 

time/frame slider and animation options, a timeline, Animations panel, and the Record Keyframes tool (found on 

the 3D Editor toolbar and the Animation controls). 

The Record Keyframe tool, in conjunction with the other 3D Editor tools, is used to edit animation. 

Animation Timeline 

The timeline shows time progressing in a graph-like display beginning at the left. It displays the current object’s 
keys, and is used to edit keys and tracks. Various other animation controls and options are available with which to 
create and modify animations. 

The Animations panel displays a list of all the components that are associated with any animation in the current 
3D file. 

A right-click context menu is also available from where you can perform a number of functions relating to 
animation. 

Repeated animation is displayed as dotted red lines in the timeline. 
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2 Viewing Keyframe Animation 
Look at an animated model and the various controls and panels with which we manipulate animations. 

1. Open the Reallight Transmission model and save the file with _animation appended to the end. 
Notice that the time display on the time/frame slider indicates that the animation is currently at second 0 
of a 3-second animation (0.00 / 3.00). 

 

2. Click Play in the Animation controls to play the entire animation, and then move the slider back and forth to 
manually play the animation. Each object has a keyframe that moves it to a second position during the 3-
second period. 

Change the time display to view the animation in frames. 

3. Click the animation controls arrow  , click Options, and then select the Frames radio button. 

 

4. Click OK. Notice the change in the time display. Now, when you play the animation the time display shows 
the current and total frames. The number of frames between the start and end of the animation is 90. 

 

We now view the animation via a timeline to see the animation keyframes and their tracks. 

5. Choose Window > Panels > Animations to display the Animations panel. Notice that the current explode 
animation displayed in the panel. 
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6. Expand the Explode node in the panel and select the fourth Allen Screw, Cap Head object in the list. 

 

7. Rotate and zoom the model to see the selected object more closely. 

 

8. Choose Window > Panels > Animation Timeline on the menu bar to display the Animations timeline. The 
selected object’s animation is displayed in the timeline. 

 

Allen Screw, Cap Head object animation 
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9. Click the Position node in the timeline. 

10. Right-click the timeline and fit the distance horizontally and/or vertically to display the entire position 
animation in the timeline. 

 

11. Move the animation slider and note how the selected screw moves between the two keyframes represented 
by two black squares. The screw’s position track stops at frame 15 of 90. So when the animation is played 
at 15 frames per second, the screw will move at a constant speed over 1 second. 

Note that the other objects also move during this animation, but we are only concerned with the selected 
screw at this time. 

You can add additional keys to animation tracks to adjust changes in speed or distance.  

12. To add a new key, right-click the position track at frame 7, then click Insert Key. The track connects 
between the keys in straight lines creating a uniform rate of change between keys. This is called linear 
interpolation. 

 

Inserting a key 

 

Linear interpolation 
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13. Right-click the timeline and choose Track Properties > TCB Interpolation to create a smoother motion with 
acceleration and deceleration. Note how the track is now curved. 

 

Animation can be created for rotation, opacity, and other object properties. SAP 3D Visual Enterprise 
Author indicates that animation is available for a property by displaying a red square around that property 
or an animation button beside the property. 

14. Double-click the screw in the viewport and click the Transformation tab page. Note the red square around 
Position, Rotation, and Scale. 

 

15. Click the Attributes tab. Notice the animation button beside the Opacity field. 
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3 Creating and Editing Sequences 
You can create a number of sequences to disassemble the gearbox starting with the screws.  
Firstly, remove the original explode animation as follows: 

1. Click the current Explode animation in the Animations panel and click Delete File to remove the animation 
from the scene. 

2. Deselect all objects. The Animation Timeline should now be empty. 

 

3. Zoom out from the scene to display the entire model and save the file. 

 

4. Select all four screws and enable Move tool on the 3D Editor toolbar. 

5. Ensure the coordinates are set to Local on the 3D Editor toolbar so that the objects move or rotate on their 
own local access. 

 

6. Click Record Keyframes  on the 3D Editor toolbar or in the Animation controls. The viewport displays 
[REC], both the viewport and the time/frame slider are highlighted in red, and a sequence appears in the 
Animations panel. 

A sequence is created automatically if none is found within the current file. It makes no difference whether 
you select the object before enabling Record Keyframes, or the other way around. The important thing to 
remember is to enable Record Keyframes for all actions that you want to include in the animation. 
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New sequence in Animations panel 

 

Viewport recording 

7. Move slider to the end. This establishes where the next keyframe is located. 

 

8. Drag the screws along the X axis to a position quite far from the rest of the model to give room for the parts 
that follow. Notice that the path for this animation is displayed. This is like a visual timeline for the 
animation with keyframes at the start and end. 

 

9. Click Record Keyframes again to stop recording. 
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10. Expand the sequence in the Animations panel and note that the transformation you performed was added 
to the sequence. 

 

11. Manually move the time/frame slider back and forth to view the sequence. 

12. Select one of the animated objects and zoom into the animation path to see the small, orange circles that 
represent the start and end keyframes. Any additional keyframes would also be displayed on the path as 
they are in the timeline. 

  

Start keyframe           End keyframe 

 

13. Click the new sequence or highlight and right-click it in the Animations panel, and then rename it 4 Screws. 

You can now create two more sequences to remove the left case and then the gears. 

14. Click Create new empty animation sequence  . A new sequence is displayed in the Animations panel. 

15. Activate the new sequence either by doing one of the following: 

 Clicking Activate  on the Animations panel toolbar 

 Double-clicking the sequence 

 Right-clicking the sequence in the Animations panel and click Activate 

The sequence name is displayed in the Animations panel and the active sequence name is displayed at the 
left of the time/frame slider. Any transformation you make from here is added to that sequence. 

 

Active sequence 
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16. Right-click the new sequence and click All Sequences to End. This ensures the next sequence begins after 
the first. Note that the slider has been moved to the end. 

 

There is a possibility to lose track of animated scenes when you work on a scene with multiple sequences. 
All Sequences to Start ensures that all objects are at their home positions. For example, if you want to 
create a sequence that did not follow on from the previous one, or if want to save the file in its home state, 
but cannot easily tell if all objects are in their initial positions. Additionally, All Sequences to End ensures 
that all objects are at their finish position to create a sequence that follows on from the former (as we have 
just seen). 

17. Click Record Keyframes again. 

18. Enable the Move tool and move the case out from the model. 

       

Case selected           Case moved 

19. Create and activate another sequence. 

20. Move the gears outwards from the main assembly. As the main camera will not be recorded, you can zoom 
into the model to ensure the correct objects are selected while still recording the scene. 

   

Zoom in and select gears            Move gears 
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21. Select each new sequence and use the F2  key to rename them as Cover and Gears respectively. 

 

22. Activate and play each sequence, and then save the file. 

The sequences so far have been created separately so that they can be played separately. Another way to 
show disassembly is to pull multiple objects apart within the same sequence. 

23. Right-click any sequence and click All Sequences to Start to reset all sequences to the beginning. 

24. Create and activate a new sequence. 

25. Move the slider to the end, start recording and pull apart the gear box all within the same sequence. 

26. Turn recording off and rename the new sequence Combined. 

 

27. Activate and play the new sequence. 
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4 Creating and Editing Steps 
Creating a step captures current camera position and other viewing properties such as object visibility and the 
render mode. A step can also contain sequences. We now put the sequences created earlier into steps of a 
procedure. 
 

1. Display the Steps and Procedures panel above the Animations panel. 

 

2. Click Create on the Steps and Procedures panel to display the Create Step dialog, and then click OK. A new 
step is created with the current camera position and the steps thumbnail is displayed in the Animations 
panel.   

The thumbnail displayed for each step is the last frame of the last animation defined in the sequence list for 
that step.  

There are several ways of loading sequences into a step. Firstly, you use the step properties. 

3. Right-click the step in the panel and click Properties. 
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4. Click the Animation tab and add the 4 Screws and Cover sequences using the following methods and then 
click OK. 

 Select the sequence and then click Add 

 Double-click the sequence 

 

Animations tab - added sequences 

 

Step 1 - added sequences 

5. Drag the Gears sequence from the Animations panel into the step. 

 

6. Play the step. The sequences are played in the order in which they appear in the step.  
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4.1 Edit Navigation and Visibility 

Now you can create steps to show how to control scene navigation and visibility. You can also modify step 
creation options so that a dummy sequence is automatically produced when the step is created. This means that 
you can quickly record animation for the sequence that is produced in the step. 

1. Click Options   on the Steps and Procedures panel toolbar. 

 

2. Select the Create a Dummy Sequence field and click OK. 

 

Steps and Procedures panel toolbar/Step Options window 

3. Ensure the animation is at the end. 

4. Press CTRL  and drag the cursor in the viewport to select the parts that have been animated. 
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5. Press H  on your keyboard to toggle the visibility of the selected parts. 

     

Selected animated objects        Hidden objects 

6. Zoom into the model to show the shaft object more clearly, and then create a new step. Notice that the 
visibility is saved within the step and that a dummy sequence has been created. You could now add an 
animation to this sequence, however you will delete for this exercise. 

 

7. Delete the dummy sequence within the Animations panel. Note that it is removed from the step. 

    

Dummy sequence           Dummy sequence removed 

8. Play the steps by clicking on their respective thumbnails in the Steps and Procedure panel. 

9. Click the procedure name in the panel and rename it Disassembly Procedure. Note that when the cursor is 
moved over the steps, animation controls appear. 
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10. Save the file. 

You can also add description to steps. This is helpful for adding details such as captions for movies, or details for 
PDF documents etc. 

4.2 Editing Options 

We now look at the various options that are available for editing steps. 

1. Open the Step Properties window for Step 1. 

2. Click the Advanced tab and consider the various options: 

 The Fly-to animation duration option is used to add extra time to the step’s animation duration. 

 You can set the navigation mode for the user if, in the end product, they have the option to navigate the 
scene. 

This is very important for users that are not familiar with 3D navigation. 

  

3. Click the Animation tab and double-click a sequence. Here, you have options for speed, delay, to play 
specific frames of that animation, and to reverse the animation. 

4. Click Cancel to close the dialog. 

Let’s edit a sequence by highlighting the screws. Highlighting objects of interest is a good way of drawing 
attention to those parts. 

5. Play the disassembly sequence and select the small screws. 

 

6. Right-click the sequence in the Animations panel and click Highlight Selection. 
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7. Select the type of highlight you want. Here we choose a continuous flash of 1 second with a light pink color 
and opacity of 50. Note that the highlight options you choose can be saved as a style. 

 

8. Click OK, deselect the screws and play the animation again to see the highlight. 

9. Right-click the sequence again and click Remove Highlight. 

10. Add a highlight for the entire sequence and play the sequence to see the changes. 

4.3 Duplicating and Reversing Steps 

Now that we have a basic assembly procedure, we now create an assembly procedure from it. 

1. Right-click the Disassembly Procedure and click Duplicate and Reverse. The new procedure appears in the 

Animations panel. 

2. Expand the procedure and note that the steps have been reversed, and the sequences are in reverse order 
producing an assembly procedure. Steps containing multiple sequences can also be individually reversed 
by right-clicking the steps and clicking Reverse Step. 

 

3. Save the file. 
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4.4 Updating Object Visibility 

1. Click Step 2 of the Disassembly Procedure and select the right case. 

 

2. Press H  on your keyboard to hide the object, right-click the step and click Update Selection Visibility. 

 

3. The step is updated however the steps thumbnail is not. This is important to note as if you update the entire 
step, all step properties are the captured including the camera position. 

The layers that are associated with multiple steps can also be used to hide object visibility. See the SAP 3S 
Visual Enterprise Author Help for further information. 

4.5 Deleting a Step 

1. Select one of the steps and delete it. You now have the option of deleting the associated layer. 

 

2. Click OK to delete the default layer. This is the typical action to take when deleting steps.  



  

How To Use Animations   

Creating and Editing Steps  © 2014 SAP AG or an SAP affiliate company. All rights reserved. 22 

4.6 Quick Step Creation 

Now we delete all existing steps and animations to learn how to recreate them again quickly. This is only one 
method of many. You may find other methods once you are more acquainted with animation. 

1. Play Step 1 of the Disassembly Procedure. The time/frame slider now shows frame 90 of a total 90 frames 
for that step, representing 3 sequences containing 30 frames each. 

2. Move the slider to the end and note how the corresponding sequences are activated automatically in the 

Animations panel. This allows for quick access to the corresponding sequence for editing. 

Note that if you do edit a sequence within a step, ensure that you are in record mode otherwise the start 
and end positions of the object will be moved. 

3. Click Reset all Steps in the Animations panel toolbar. 

4. Delete all procedures and animations. 

5. Ensure the Create a Dummy Sequence option is selected in the Steps Options window and turn on record 
mode. 

6. Right-click the Steps and Procedures panel and click New Procedure. 

7. Move the slider to the end and add a step. 

8. Select and move the screws out from the cover. 

9. Add a second step and move the cover towards the screws. 

10. Add a third step and move the gears towards the cover. 

11. Zoom into the shaft object and create last step. 

12. Duplicate and reverse the procedure. 

13. Right-click each procedure and click Play  . 

            

Multiple steps within procedure   Play procedure 

14. Save the file. 

As you can see, creating sequences within steps, and steps within procedures can be very fast.  
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5 Tracks and Keys 
You can gain greater control over animations by specifying the properties of the tracks and keys. We now look in 
greater detail at these elements of animation. 

1. Rename the sequence that moves the screws to Screws. 

2. Rename the sequences that move the cover and gears to Cover and Gears respectively. 

3. Rename the sequence that zooms into the shaft to Shaft. 

4. Set all sequences to the start and save the file. 

5. Activate and play the Screws sequence to the end, then activate and play the Cover sequence to the end. 

 

6. Expand the Cover sequence and select the cover object. Note the display in the timeline. 

 

Animations panel - expanded sequence 

 

Cover object timeline 

7. Click the Position, Rotation, and Scale nodes in the timeline. Note how there is only there is only position 
animation with no rotation or scale animation. 

8. Move the time/frame slider and see how the timeline’s time/frame line moves in harmony with the slider. 

9. Click the Position node, right-click frame 22 and add a key. 
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10. Move your cursor over the new axis key. The value of the key is displayed. 

 

11. Double-click the key you wish to edit, or right-click the key and click Key Properties. Note that the key color 
turns white in the timeline when it is selected. 

 

12. Change the X axis property to -0.02. The key moves to the new position in the timeline. 

13. Click Close and play the sequence 

Note the change in speed at frame 22. 

 

14. Click the new key again to select it, and move your cursor over the selected key. 

15. When the cursor displays as 4-arrows , drag it to another position. 

16. Play the sequence again and note the difference in speed at the new frame. 

You can see how animations can be edited precisely using the animation tracks and keys. We now add a 
rotation animation to one of the gears and look at the keys that are created. 
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17. Activate and play the Gears sequence to the end, select the 52-Diff Gear object, and then drag the slider to 
frame 15. 

 

18. Move to record mode and rotate the gear clockwise several times on the X axis by dragging downwards in 
the viewport with the X axis highlighted. 

 

19. Turn off record mode and use the slider to view the animation. Note that the gear rotates at the same time 
as it moves outwards from the model. 

20. Select the Rotation node for the modified gear in the timeline and consider the new keys. 

21. Try moving the rotation keys and play the sequence to see your changes. 
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5.1 Modify Sequence Length 

1. Reopen Reallight Transmission_animation.rh without saving any changes. 

2. Open the Animation Options window and change the time display to seconds. 

 

3. Close the window, and activate and play the Cover sequence. Note that the time it takes to play the 
animation should be 1 second. 

4. Open the Animation Options window again, select the Cover sequence and then click Edit. 

5. Increase the end time to 2 seconds and click OK twice. 

 

6. Replay the animation. The animation length has been doubled. Note that the end of the position animation 
now displays as 1 of 2 seconds and beyond 1 second there is no animation. 
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7. Drag the slider to the last frame (2 seconds), right-click the timeline and click Fit Horizontally to view the 
entire animation. 

 

8. Drag the end key of the position animation to the last frame. 

 

9. Play the sequence and note that the cover takes twice as long to move to the same place within the scene. 

10. Play the procedure from the Steps and Procedure panel and see how the cover moves at a slower rate than 
the other animated objects. 

11. Close the file without saving it.  
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6 Creating an Exploded Animation 
We now create an animated sequence to show an exploded view of a parts assembly. 

1. Open COOPER PB-ASY-IN - steps.rh, delete the existing sequences and procedure and save the model 
with _explodeanimation appended to the name. 

2. Display the Drawing toolbar. 

 

3. Click the Explode Objects arrow and click Settings. 

4. Select the Create Animation and Create Animation Sequence for Each Stage checkboxes, and change the 
Stages field to 1. 

 

5. Click OK to close the dialog, zoom out of the scene an click Explode Objects . The exploded sequence 
appears in the Animations panel. 

6. Expand and view the sequence. 

 

7. Play the animation and save the file. 
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8. You could now edit the animation to ensure that the parts explode out from the model at logical times. 
Once you are satisfied with the result, you could then duplicate and reverse the explode sequence to show 
the re-assembly.  
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7 Rendering Animation 

7.1 Rendering Animation to 2D 

1. Choose Render > Render To File  on the Render toolbar. 

 

Render toolbar 

2. Choose a destination, a file name, and a 2D file type. Here, we select the .bmp format. 

3. Select the All animation sequence... radio button, and then click Save. 

 

Note that the All animation sequence… name displays the number of frames or seconds of the current 
animation, depending on the option selected in the Animation Options window. 

4. Click Save. Each step of the animation is saved as a separate file. 

5. Open the files from within the destination in which they were saved.  

            

2D rendered animations 1st, 27th, 43rd, and 89th files 

7.2 Rendering Animation to Video 

1. Reopen COOPER PB-ASY-IN - steps_explodeanimation and choose Render > Auto-Fly-Around on 
the Render toolbar. 

2. Choose a destination, file name, and the .avi file type. 

3. Click Save. 

4. Open the .avi file and experiment using the video controls. 

 
Video controls 
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