How To Protect your Intellectual Property
## Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Example</td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Textual cross-references to other documents.</td>
</tr>
<tr>
<td>Example</td>
<td>Emphasized words or expressions.</td>
</tr>
<tr>
<td>EXAMPLE</td>
<td>Technical names of system objects. These include report names, program names, transaction codes, table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE.</td>
</tr>
<tr>
<td>Example</td>
<td>Output on the screen. This includes file and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td>Example</td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td>&lt;Example&gt;</td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td>EXAMPLE</td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>
Document History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>2015-01-22</td>
<td>First Version</td>
</tr>
</tbody>
</table>
# Table of Contents

1. **Introduction** ......................................................................................................................... 5  
   1.1 Purpose ............................................................................................................................... 5  
   1.2 Prerequisites ....................................................................................................................... 5  

2. **Removing Metadata** ............................................................................................................ 6  
   2.1 Removing all Metadata ....................................................................................................... 6  
   2.2 Removing Selected Metadata Keys .................................................................................... 6  
   2.3 Alternative Method for Removing CAD Metadata ................................................................. 9  

3. **PMI GD&T** ........................................................................................................................... 10  
   3.1 Removing PMI .................................................................................................................... 10  

4. **Internal Details** .................................................................................................................. 13  
   4.1 Removing Internal Details ................................................................................................. 14  

5. **Small Details** ...................................................................................................................... 16  
   5.1 Removing Small Details ..................................................................................................... 16  

6. **Collapsing an Assembly** ..................................................................................................... 18  
   6.1 Converting an Assembly into a Monolithic Object ............................................................. 18  

7. **Obfuscating Geometry** ......................................................................................................... 19  
   7.1 Randomizing Objects ......................................................................................................... 19  

8. **Simplifying Geometry** .......................................................................................................... 20  
   8.1 Reducing Models ............................................................................................................... 20  

9. **Measurements and conversion protection of .RH or .VDS files** ......................................... 21  
   9.1 Setting Measurement and Conversion Protection ............................................................... 21  

10. **Encrypting .rh or .vds files** ................................................................................................. 24  
   10.1 Setting Encryption ............................................................................................................ 24
1 Introduction

1.1 Purpose

Product lifecycle management often requires people involved in processes to have access to 3D engineering and design data in order to make informed decisions. SAP 3D Visual Enterprise Author contains a number of tools to remove sensitive data before .zh files are released to external customers, partners, vendors, or manufacturers.

1.2 Prerequisites

- You should be familiar with 3D concepts
- You should be familiar in the use of SAP 3D Visual Enterprise Author

The following software and files are required:
- SAP 3D Visual Enterprise Author version 7.1 or v8
2 Removing Metadata

The first step is to remove all metadata contained within files.

2.1 Removing all Metadata

1. Load the file.
2. Click Purge Scene on the 3D Editor toolbar. The Purge Scene window will display.

![Purge Scene window]

3. Select the Any Metadata checkbox.
4. Choose Process, then choose Close.
5. Save the file.

2.2 Removing Selected Metadata Keys

1. Load the file
2. Open the Metadata Panel from the main menu by selecting Window → Panels → Metadata
3. Click *Select Metadata Keys to Show* [ ![ ] ]. The *Select Columns* window will display.
4. Select the metadata key to delete, and choose **Remove**.

5. Choose **Remove From Scene**:

   ![Metadata removal dialog](image1)

   - **Key 'MATL_DESC' will be removed**
   - **Do you want to continue?**
     - **Remove From Selected**
     - **Remove From Scene**
     - **Cancel**

6. Save the file.

   **Caution**

   This method does not permit you to remove metadata imported from CAD packages. This metadata is grouped under the **CADMetadata** category:

   ![Select columns dialog](image2)

   CAD metadata is read-only and must be deleted using the **Purge Scene** command.
2.3 Alternative Method for Removing CAD Metadata

An alternative option for removing CAD metadata is to re-convert the original CAD assembly, and in the Import settings window, set Import Metadata to No:

![Import Properties of CATIA5 Part files]

[Diagram showing settings with Import Metadata set to No]
3 PMI GD&T

PMI information is imported into .rhd files as text and vector graphics under the “PMI” or “PMI entity” group objects:

Or

3.1 Removing PMI

To remove PMI information, proceed as follows:
1. In the Main menu, select Edit → Select Objects to open the Select Objects window.
2. Select the Name tab page.
3. Search for PMI objects by typing **PMI** in the *Search For* field, and clicking *Search*.
4. Choose **Select**, and then press **DELETE** on your keyboard to delete the selected PMI objects.
5. Close the **Select Objects** window.
6. Save the file.

   **Note**

   This operation can be automated using Query.
4 Internal Details

Removing hidden detail allows you to create an outer shell of an assembly part.

Example

The following example shows an original assembly:

The assembly has a complex internal structure:
4.1 Removing Internal Details

1. From the CAD Tools toolbar, select Remove Hidden Objects. The Remove Hidden Objects window will display.
2. Select Analyse Whole Scene and Process: Polygons.
3. Choose OK.
4. All hidden geometry is removed.
5. Save the file.

Note

The processing time may be lengthy when processing large and complex assemblies.
**Example**

After performing this process, the following example shows that the assembly looks the same visually:

![Assembly example](image)

However, all insides were trimmed:

![Assembly inside](image)
5 Small Details

5.1 Removing Small Details

To remove small parts, proceed as follows:

1. In the Main menu, select Edit → Select Objects to open the Select Objects window.
2. Select the Size tab page.
3. Use the slider to select the required bounding box diagonal. In real-time, a list of matching objects is updated.
4. Choose Select to select matching objects, and then press DELETE on your keyboard to delete those objects.
5. Close the Select Objects window.
6. Save the file.

Note

This operation can be automated with Query
6 Collapsing an Assembly

Another simple way to hide the internal structure of an assembly is by turning it into a monolithic object. This procedure takes an assembly and converts it.

6.1 Converting an Assembly into a Monolithic Object

1. Load the required file.
2. Select the top level of the assembly in the Scene Panel.
3. Right-click to access the context menu, and choose Tools → Collapse Hierarchy.
4. Save the file.

All geometry is merged into a single 3D mesh.
7 Obfuscating Geometry

You can distort the 3D geometry in your model and protect it from precise measurements. This procedure ‘randomizes’ the objects in the file, so that precise measurement is impossible.

7.1 Randomizing Objects

1. Load the required file.
2. From the CAD Tools toolbar, choose Randomize Objects ➔ Settings ➔.

   ![CAD Tools screenshot](image)

   **Note**
   
   If no parts are selected in the scene, this tool will affect all parts. If parts are selected, the tool will work with the selected parts only.

3. In the Randomize Objects Settings window, set the desired tolerance, and close the window.

   **Recommendation**
   
   The default tolerance is recommended as an optimal value which will not distort geometry too much visually.

4. From the CAD Tools toolbar, choose Randomize Objects. The geometry is distorted.

   **Note**
   
   You may need to re-adjust the settings if the visual quality is very poor.

5. Save the file.
8 Simplifying Geometry

You can remove small features of 3D geometry and simultaneously reduce the file size.

8.1 Reducing Models

1. Load the required file.
2. From the CAD Tools toolbar choose Reduce Model. The Reduce Model window will open.
3. Select your required settings. The default setting with Remove % set to: 70 – 80 % produces reasonable visual quality with approximately 30 – 50 % file size reduction.

4. Click Process to apply the reduction.

   More memory may be required if polygon reductions take time to complete. For example, if there are many parts in a model, or a complex assembly.

5. Ensure that the visual quality adequate, if not repeat the process with a lower percentage setting.
6. Save the file
9 Measurements and conversion protection of .RH or .VDS files

The .rh and .vds files have built-in protection from measurements and conversion. These settings apply to all SAP 3D Visual Enterprise applications and viewers.

⚠️ Caution

This method, however, does not guarantee absolute protection. There are ways to reverse engineer application and file formats, given enough time and resources.

This procedure describes how to set conversion protection.

9.1 Setting Measurement and Conversion Protection

1. Prior to saving an .rh or .vds file, open the file settings by choosing Settings in the Save As window.
2. In the Export Properties window, choose the following settings:
   - Disable Measurements: Yes.
   - File Protection: Conversion Protected

Example

The following example shows the settings for the .rh format:

![Example](image)

Example

The following example shows the settings for the .vds format
3. Click **OK** and save the file.
10 Encrypting .rh or .vds files

The .rh and .vds file formats support password encryption. A password can be set on file save, which means that the file recipient can open the file only after entering the correct password.

⚠️ Caution

This method does not guarantee absolute protection. There are ways to reverse engineer application and file formats, given enough time and resources.

This procedure describes how to set encryption for your files.

10.1 Setting Encryption

1. Prior to saving an .rh or .vds file, open the file settings by choosing Settings in the Save As window.

2. In the Export Properties window, set Password Encrypted to Yes.
3. Click **OK** and save the file.

The *Saving with Password* window will display.

4. Type in the required password.

   **Recommendation**

   We recommend that you choose a complex enough password to ensure encryption strength.

5. Click **OK**. The file is encrypted and saved.