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1 Introduction 
Steps and procedures can be described as containers. Procedures contain the steps and control the order in 
which they are played. Steps are containers that hold and control sequences and the visibility of objects. Steps 
also store the camera position (view), lighting, and display render types. You can use steps to highlight specific 
objects and/or all the animated objects within the step to draw attention to important objects.  

In this guide you can learn how to do the following: 

 Play steps and procedures 

 Create and delete steps and procedures 

 Create and delete sequences 

 Update sequences and object visibility 

 Create highlights 

 Assign consumed parts to a step 

 Save 

 Publish to HTML and Adobe PDF 

Prerequisites 

This guide assumes you have a basic knowledge of SAP 3D Visual Enterprise Author.  

You should know how to do the following: 

 Move about the interface 

 Hide and show panels 

 Select and deselect objects 

 Hide and show objects 

 Transform objects (move, scale and rotate) 

 Change your view by zooming, rotating and panning 
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2 Steps and Procedures 

2.1 Opening a File in SAP 3D Visual Enterprise Author 8.0 

For this example we will load the COOPER PB-ASY-IN - steps.rh file located in the My 3D Models tab page. 

To load the COOPER PB-ASY-IN - steps.rh, do the following: 

 

1. Ensure the My 3D Models panel is open by selecting Window> Panels>My 3D Models. 

 

 

2. Left click on the Cooper PB-ASY-IN – steps.rh file. 

 

Note:  If the Import Properties of SAP 3D Visual Enterprise Binary window  opens, then choose OK to open the file. 

Once the file has opened you will see the 3D model in the Workspace.  
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Now make sure both the Animation panel and Steps and Procedures panel are visible by doing the following: 

1. Click on Window>Panels>Animation 

 
2. Click on Window> Panels> Steps and Procedures 

 

Note: Panels that are open have a check mark next to them. 

Now let’s play through the steps to see an example of what steps and procedures should look like. There are many 
ways to play a single step or to play through the entire procedure. 

To play a single step, do the following. 

1. In your Steps and Procedures panel do one of the following: 

o Right click on any step and select Play 

o Double click on the step 

o Move you mouse courser over the thumbnail in the step and click on the right Play button. 

Note that the button on the left will reset the step to the beginning. 
 

                                         

 

You can also select the step and press the Play button in the toolbar at the top of the panel.  
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To play the entire procedure, do one of the following: 

 Right click on the word Procedure and select Play 

 

 Double click on the word procedure 

 Select the procedure and press the Play button in the toolbar at the top of the panel.  

 

 

2.2 Deleting a Procedure 

We will start by deleting the procedure and the sequences that are currently in this file. That way we can start with 
a clean file.  

To delete a procedure, do the following: 

1. Right click on the first step and select Reset to get all the parts back into their original position. 

2. Click on the Steps and Procedures tab page to show the Steps and Procedures panel. 

3. Right click on Procedure 1 and select Delete Procedure. 
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To delete all of the sequences in the Animation panel do the following: 

1. Click on the Animations tab page to show the Animations panel. 

2. Click on the top sequence.   

3. While holding Shift , click on the bottom sequence to select all the sequences. 

4. Click on the Red X, which is the Delete Animation Sequence button, in the row of buttons at the top of the 

Animation panel. 

 

Now use Save As to save the file with a new name on your Desktop or another folder where you can quickly find it. 

To use Save As, do the following: 

1. Select File. 

2. Select Save As 

3. In the dialog box, navigate to your Desktop 

4. Save file with new name 

Note: You should remember to save your file often and iteratively in order to back up your work as you go. 

2.3 Creating a Step and a Procedure 

 

When you first open a new file your file will not contain any steps or procedures or any animations.  

To create a procedure, do the following  

1. Ensure the Steps and Procedure panel is open 

2. Right click in the blank area below the toolbar in the Steps and Procedures panel and select New 

Procedure. 

 

To create a step, do the following: 
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1. From the Steps and Procedures panel click on Create tool which is the first Icon in the toolbar at the top of 

the panel. 

 

2. The Step Properties window opens. You can change the step name and give it a description. 

 

3. Leave the Name field as Step 1.  

4. In the Description area left click and enter Cooper Bearing Assembly. 

5. Click OK. 

You have now created your first step and procedure. 

Note:  A procedure will automatically be created if one does not exist and you click on Create to create a step. 

Create a second step by repeating the steps above. We will keep the Name as Step 2 and enter Remove #500 

bolts in the Description field. 

   

2.4 Creating a Sequence 

Creating a sequence is a five step process in which you do the following: 

1. Create a sequence 
2. Activate a sequence 
3. Turn on record keyframes 
4. Make changes to the objects position, rotation, scale and opacity 
5. Turn off record keyframes 

A sequence is made of frames and keyframes. The number of frames dictates the length of the sequence, for 
example, if you have 30 frames in a sequence and your animation is running at 30 frames per second, you have a 
one second animation. Each keyframe can record the position, rotation, scale, and opacity of objects.  Keyframes 
need to be set for each important state (position, rotation, scale, and or opacity). When you create a keyframe on 
the last frame of a sequence, SAP 3D Visual Enterprise Author automatically creates a keyframe on the first frame 
for you.  

Next we will create an animation of the bolts being removed from the assembly to add to our second step. 

Create a new sequence by doing the following: 
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1. Ensure the Animation panel is open as described above. 

2. Click on the Create Sequence tool which is the first icon in the Animation panel toolbar. 

 

You will see that a new sequence has been created and is called Sequence-1. We recommend to rename the new 
sequences to something relevant so you can quickly locate it as your list of sequences grows. 

To rename the sequence do the following: 

1. Right click on the sequence and select Properties. 

2. At the top in the Name field enter Remove #500 Bolts 

3. Select OK 

 

Animating the bolts will require us to create keyframes to tell SAP 3D Visual Enterprise Author where the bolts 
starting position is and where it’s finishing position will be.  

To create an animation, do the following: 

1. Ensure the 3D Editor toolbar is showing by navigating to Window>Toolbars>3D Editor 

 

2. In the 3D Editor toolbar choose the Select tool 

 

3. Now select the two bolts on the top of the bearing assembly by holding the Ctrl  key while selecting each 

bolt. 
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4. Activate the Sequence in the Animation panel by right clicking on the sequence and choosing Activate. 

 

5. Now we need to start recording keyframes by selecting Record Keyframes in the 3D Editor toolbar. 

 

Note: A red box will be shown around the workspace and a red [REC] will be shown in the upper right hand corner 
to indicate you are recording keyframes. The Animation Controls will also be show at the bottom of the screen. 

 

6. Left click, hold and drag to slide the Timeline slider in the Animation Controls all the way to the right to 

frame 30. 
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Now we need to move the bolts to their final location by selecting the Move tool in the 3D Editor toolbar and 
moving the bolts up and away from the bearing assembly. 

To move an object, do the following 

1. Ensure the 3D Editor toolbar is open. 

2. Select the Move tool. 

 

3. Click and hold the arrow pointing up and drag the mouse up. 

Note:  The arrow will turn yellow when you hover over it.

 

4. Now turn off the Record Keyframes tool by clicking on   again.  

5. Finally, we will drag the new sequence to Step 2, by left clicking and holding while dragging the sequence 

to Step 2 and then releasing the mouse button over the step. 

Let’s create another step to show the workflow for creating multiple steps. 

1. Click on Step 2. 

2. Create a new step and enter Remove bearing top in the step description (for more information, see 

Creating a Step and Procedure). 

3. Now create a new sequence and name it Remove bearing top (for more information,  see Creating a 

Sequence) 

4. Double click on the new sequence to activate it. 

5. Turn on Record Keyframes. 

6. Move the timeline slider to frame 30 by sliding it all the way to the right. 

7. Select the top of the bearing. 
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8. Move the top bearing up away from the rest of the assembly. 

9. Turn off Record Keyframes. 

10. Drag and drop the new sequence to Step 3. 

2.5 Viewing Steps and Procedures 

To view what we have created, do the following: 

1. In the Steps and Procedures panel select the procedure and click on the Play button in the toolbar or 

simply double click on procedure. 

  

Notice how on the third step the bolts are still visible even though we removed them in the second step. We need 
to hide them from view in the third step. To hide them we need to select them and hide them. Then update the 
step. 

 

 

 

 



  

Steps and Procedures Quick Start   

Steps and Procedures  © 2014 SAP AG or an SAP affiliate company. All rights reserved. 14 

To hide objects and update steps, do the following: 

1. Play step two by hovering over the thumbnail and pressing the play button on the right or by double 

clicking the step itself. The button on the left resets the step to the beginning. 

  

2. Select both bolts by clicking on each while holding CTRL  down. 

3. With both bolts selected right click on the work area and select Hide Selection or choose  H  on the 

keyboard. This will hide the bolts. 

4. With the bolts still selected but hidden right click on step 3 and select Update Selection Visibility. 

Now that you have made your first three steps you may need to update your thumbnails for one or more step as 
they may be showing large red, green and blue lines. 

 

For each step that needs to be updated, do the following: 

1. Play the step. 

2. Ensure all objects are deselected. 

3. Right click on your step and select Update Step. 

Notice how the Thumbnail updates. Repeat on any step that needs to be updated. 

Double click on procedure again to watch all the steps again. 

Save your file using Save As to your desktop with the same name as before but add an_01 at the end.  

Result 

In this section we created a procedure, three Steps, and two Sequences. We learned how to select and move 
multiple objects.  Finally we learned how to view our work. On your own create three more steps.  The first of these 
steps should show the removal of the bearing from the assembly.  Next you will show the four screws holding the 
bearing together being removed and then the last step will show the two halves of the bearing being separated. 
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2.6 Creating Highlights in a Step 

Highlights are used to draw attention to objects or all the animated objects within your step. Highlighting is not 
permanent. You will only see the highlight when the step is played. The highlighted items will not have this effect 
on them in any other step unless otherwise specified. 

To add highlights to selected items, do the following: 

1. Select the items in your step you want to highlight. 

2. Right click on the step. 

3. Select Highlight Selection. 

 

Alternatively you can do the following from the steps properties. 

1. Select the items to be highlighted. 

2. Right click on the step and select Step Properties. 

 

3. Click on the Highlights tab page. 

4. Click on New form selection 
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The Highlights Properties panel opens and prompts you to decide how your highlight should look. SAP 3D Visual 
Enterprise Author has many predefined appearances for highlights, and you can save and distribute your own. 

 

To create a highlight that will flash yellow for 10 flashes, do the following: 

1. Select One or Several Flashes 

2. Enter 10 in the Cycles Of field 

3. Click on the Color to make changes 

To change the color to yellow, do the following: 

1. Enter 255,255,0 in the RGB field of the Color Picker 

2. Choose OK at the bottom of the Color Picker 

3. Choose OK again at the bottom of the Highlight Selection window. 

 

4. Right click and choose Select None to deselect the object 
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Now when you play the step you will see the selected highlighted item will be yellow in color. 

 

 

To make changes to the Highlight in a Step, do the following: 

1. Right click on the step with the highlight. 

2. Select Properties at the bottom. 

3. Select the Highlighting tab page in the Step Properties window. 

4. Select the highlight. 

 

5. Click on Properties (See below for a description of options) 

6. Make your changes and click OK at the bottom to accept the changes. 

 

 

 

 

 

 

 

 



  

Steps and Procedures Quick Start   

Steps and Procedures  © 2014 SAP AG or an SAP affiliate company. All rights reserved. 18 

Highlight Options Window 

 

1. This area allows you to choose a preset from the dropdown or save and delete presets. 

2. Allows you to set a specific highlight as the default highlight or clear the current default highlight. 

3. Highlight Types 

 Static Highlight:  Will make a constant highlight that does not flash 

 One or Several Flashes: Will cause the highlight to flash a set number of times and is controlled 

by the cycles of and seconds. 

 Continuous Flash: Will flash continuously and is controlled by the seconds. 

4. Flash Controls 

a. Cycles of: Controls the number of flashes. 

b. Seconds: Controls the duration of the flash (on/off). For example, if you want the flash to be on 

for a half second and off for a half second,  enter .5. 

c. Total Duration: Shows the total duration of the flashes or can be used instead of the seconds if 

you know how long you want the flashing to last. For example, if you know you want 16 flashes 

over 3.5 seconds and you do not want to do the math to figure out how many flashes per second 

that is, you can use the total duration and the software will figure it out for you. 

5. Dictates the color and/or opacity of the highlighted items. 

6. Allows you to assign another color or the object color to the off state of the flashing highlights. 
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Another option to change the appearance of objects in a step using the highlights is to make changes to the 
opacity of non-highlighted objects. This will make all non-highlighted items semi-opaque.  

To make changes to the opacity of non-highlighted objects, do the following: 

1. Right click on the step with the highlight and select Properties at the bottom. 

2. Select the Highlighting tab page in the Step Properties window. 

3. Change the value of the Non-Highlighted Objects opacity to 50% numerically or by using the up and down 

arrows. 

 
4. Select OK and push Play to see the changes. 

 

2.7 Using Steps to Create Assignments 

Assignments can allow you to show consumed parts in a step. When using assignments you have the ability to add 
highlights to the consumed parts as well. 

To add assignments to parts in a step to show as Consumed, do the following: 

1. Select the parts in your step that you want to show as Consumed. 

2. Right click on the step and select Add Assignment (toward the bottom of the list). 
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The Assignment Properties window opens. Choose the following options: 

1. Select Consumed from the Assignment Type drop down. 

2. If you wish add a static highlight to the selected parts you may change color by clicking on the Change 

button. 

3. If you do not want to highlight the selected parts, click in No Highlight box. 

4. Click on OK to accept these options. 

 

Now there will be a Consumed parts list under the step. To expand the Consumed list, you will need to click on the 

(plus sign) next to the Consumed field. 
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2.8 Publishing 

Once you are finished with your file you will want to save it and then publish it. Publishing your file will allow you to 
package up the file as a 3D HTML document, an Adobe 3D PDF, or as a .VDS file.  

To publish your file to HTML, do the following: 

1. Click on File and choose Publish. 

2. Navigate to a folder you can quickly find (we recommend that you create a new folder on your desk top). 

3. Name your file. 

4. Select the Save as type as an HTML Document with 3D (*.html). 

5. Choose a template by clicking on Settings. 
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The Export Properties of HTML Document with 3D window opens. Here we can select a template to use. These 
templates are customizable and can be distributed.  

To select a template, do the following: 

1. Using the scroll bar on the right side select the 3D Steps and Procedures Template. 

Note: You will see a thumbnail to the left when you select a template. 

2. Select Start Browsing Program After Publishing window, and click on OK. 

 

To publish the file, click on Save. 

When the file is finished publishing, your browser will open and the file will start automatically. 
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To publish your file to an Adobe PDF, do the following: 

1. Click on File and select Publish. 

2. Navigate to a folder you can quickly find (we recommend that you create a new folder on your desk 

top). 

3. Name your file. 

4. Select the Save as type as an Adobe Portable Document 3D (*.pdf). 

5. Choose a template by clicking on Settings. 
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The Export Properties of Adobe Portable Document 3D window opens. Here we can select a template to use. These 
templates are customizable and can be distributed.  

To select a template, do the following: 

1. Using the scroll bar on the right side Select the 3D Steps Simple Template. 

Note: You will see a thumbnail to the left when you select a template. 

2. Select Start Adobe Acrobat After Publishing. 

3. Click on OK. 

 

To publish the file, click on Save. 

When the file is finished publishing your file will open automatically in Adobe Acrobat. 
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2.9 Useful Links 

 

 Link to SAP Store: https://store.sap.com  search for “Visual Enterprise” 

 For the Windows Viewer: 
https://store.sap.com/sap/cp/ui/resources/store/html/SolutionDetails.html?pid=0000000233&catI
D=&pcntry=US&sap-language=EN&_cp_id=id-1397075360775-0  

 For mobile devices both iOS and Android: 
https://store.sap.com/sap/cp/ui/resources/store/html/SolutionDetails.html?pid=0000004921&catI
D=&pcntry=US&sap-language=EN&_cp_id=id-1397075154296-0  

 

 

 

 

 

https://store.sap.com/
https://store.sap.com/sap/cp/ui/resources/store/html/SolutionDetails.html?pid=0000000233&catID=&pcntry=US&sap-language=EN&_cp_id=id-1397075360775-0
https://store.sap.com/sap/cp/ui/resources/store/html/SolutionDetails.html?pid=0000000233&catID=&pcntry=US&sap-language=EN&_cp_id=id-1397075360775-0
https://store.sap.com/sap/cp/ui/resources/store/html/SolutionDetails.html?pid=0000004921&catID=&pcntry=US&sap-language=EN&_cp_id=id-1397075154296-0
https://store.sap.com/sap/cp/ui/resources/store/html/SolutionDetails.html?pid=0000004921&catID=&pcntry=US&sap-language=EN&_cp_id=id-1397075154296-0
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