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1 Introduction 
Materials are composed of composite layers that reflect the material’s properties, and are designed to display 
primarily the attributes associated with maps and applied textures: 

 The Materials list displays the materials as thumbnails, which helps to identify them 

 Materials are controlled in a number of ways using the Materials folder, Materials list, Display menu, and 
Object and Material Properties windows 

 You can choose to display the scene's default material, or any other materials that have been applied to 
the scene's objects. Note that when the default material is used, the scene's materials are not displayed. 

Note 
Scene materials are not displayed when the default material is used, and the default is helpful when reviewing files 
with very light or dark materials; the object geometry is easier to see, as you are not distracted by reflections and 
highlights. 

 They can be saved as single material files and groups of materials, and then shared between users to 
create consistency between deliverables 

 Keyboard shortcuts are available for the display of materials and textures 
 
In this guide you can learn how to do the following: 

 Apply the default material to objects 

 Apply transparency and textures to materials 

 Create and replace materials 

 Rename materials 

 Save singular and grouped materials 

 Understand the different properties common to all materials 

 Be able to edit, merge, and sort materials 

 Remove unused materials 

 Apply materials to elements of a model 

 Apply and export texture maps 

 Map UV coordinates on a model 

 Use Realighting to make models more realistic 
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2 Default Material, Transparency and Textures 
 

1. Open the Automotive Crossmember Example with Steps model and zoom into the detail. 

2. Choose Display > Materials > Use Default Material   on the Navigation toolbar to apply the default 
material. 

      
No default material                                                       Default material 
 
In the first image, the material’s gloss level is 0, meaning it has broad highlights, so it tends to lose details when 
viewed from certain angles. The default material is applied in the second image. Although we are looking at the 
same object from the same angle and under the same lighting conditions, certain details become more 
discernible. 

3. Open the Reallight Transmission model, and then choose Display > Materials > Show Transparency  to 
show any transparent materials. 

        
No transparency or textures                                        Transparency displayed 

4. Click Show Textures  to display any textures. 

 
Textures displayed 
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3 Creating and Replacing Materials 

1. Right-click a material or the Materials folder in the Scene tree and click Create Material  .The material 
is added alphabetically to the Materials folder and to the end of each Materials list. 
 

 
2. Create another material by clicking Create Material on the Materials list toolbar, or right-clicking the 

Materials panel and clicking Create Material. 
3. Double-click one of the new materials to open the Material Properties window. 
4. Modify the ambient and diffuse colors on the Basic tab page, and then click OK. The material’s thumbnail 

reflects your changes in the Materials panel. We describe editing maps in more detail later. 

      
Material Properties window           Modified thumbnail 

5. Ensure the default material is not applied and drag the modified material onto the 69-Right Case and 69-
Right Case objects in the viewport. 

 

6. Click Small  on the Materials panel toolbar to view all the scene’s materials. 
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                  Materials panel toolbar  

7. Drag the modified material onto the 47-Diff Half object. The original material is replaced immediately. 

 
8. Deselect any objects, right-click the driven gear material thumbnail and click Select Objects. All the 

objects that use that material are selected; in this case, the 81-Primary Driven Gear object. 

 
9. Drag the modified material to the selected object. 

 
 

Note 
When you drag a material to an object that has that same material already applied, you can choose to replace the 
entire material on all the materials objects (Replace hit material), or you can replace the material on only the 
object to which you are dragging (Paint objects). This helps if you have a scene with two or more objects that 
share the same material and you want to make the objects more distinguishable. 
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4 Renaming and Saving Materials 

1. Right-click your modified material and click Rename  . 
2. Give the material a new name. 

 
3. Do one of the following: 

 Right-click the renamed material and click Save Material As. 

 Choose File > Save As on the menu bar and select Right Hemisphere Material (*.rhm)’ in the Save as Type 
field. 
 You are automatically directed to the SAP 3D Visual Enterprise Author Example Files folder. 

4. Navigate to another folder if you want to save the file in another location. The default folder in which 
material files are stored is C:\Program Files\Right Hemisphere\Visual Enterprise Author 
(version)\Materials. 

5. Give the material file a name and click Settings. Note the options that are available when saving new 
materials. 

 
6. Click the Texture Maps tab. Ensure the Save Textures and Include textures in 3D File options are selected. 

 
7. Click Save. 
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5 Removing, Merging and Sorting Materials 
1. Click Action on the Materials list toolbar or right-click the Materials folder. 

 

      
Action menu                                       Materials folder menu 

2. Click Remove Unused Materials. The material you created earlier but did not apply to any objects is 
removed. 

3. Drag the default material to the 81-Primary Driven Gear object. Any material that was applied to that 
object is removed. 

 
4. Right-click the material you named earlier and click Duplicate. An identical material is created. 

 
5. Choose Action > Merge Duplicate Materials on the Materials panel toolbar. All duplicates are merged. 

6. Click Link Selection  on the toolbar and click each material in the panel to auto-select all objects that 
use the material. 
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Objects belonging to case etc material 

 
Objects belonging to screws material 

 
Objects belonging to Test material material 

7. Right-click the Materials folder in the Scene tree and try sorting materials by name. 
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6 Editing Materials 
The layers that comprise a material encompass various properties that control the material’s appearance. These 

properties can be edited to change any map and texture attributes associated with the material, thus changing the 

material’s appearance. 

In the next step, we edit a material’s standard lighting properties. To understand these properties, it is important 
to have an understanding of the different lighting types. 

at where a wall meets the ceiling; it appears to have a different color when it is in shadow. 

 Diffuse lighting is the base color 

 Specular lighting is the highlights that appear on an object; the color you see in the shiny spots on an 
object 

 Emissive lighting represents self-illumination. This is usually used when you have an object that glows, 
such as an LED or headlights that are turned on. 

 Opacity is how opaque or transparent the material is 

 Glossiness represents how shiny the material is. That is, together with the specular level, it defines the 
size of the highlight. 

 Specular level, together with glossiness, helps define the size of the highlight. The apex of the curve 
represents pure specular color and the valley of the curve represents the diffused color. 

 
1. Open the Bevel gear assembly model, and then save it with -materials appended to the name. 
2. Create and rename a new material. 
3. Apply the material to at least one large object in the scene and zoom into the object to view it in more 

detail. 
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4. Open the Material Properties window for one of the materials by one of the following methods. 
The options differ depending on the type of material. Here we are editing a Standard material. 

 Double-click the material name. 

 Right-click the material, then click Material Properties. 

 Double-click the object to which the material is applied, click the Materials tab page, and then click 
Material Properties. 

 
 
You are able to use material properties to create keyframe animation. For example, you could vary the 
amount for each layer and switch materials on an object during an animation sequence. 
5. Use the material properties to edit the material’s name.  
6. Use the Basic tab page to modify the material’s ambient, diffuse, specular, and emissive lighting. Notice 

that the material itself and the material thumbnail change colour immediately.  

Note  
If a highlight colour is used for selected objects, you must deselect the objects to be able to see any changes to 
the material. Alternatively, you can edit the highlight preference via Edit > Preferences > Colors > Selection 
highlight. 
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Basic tab page modified name and lighting         Viewport display 

7. Experiment with the other material properties. For example, opacity, raytrace reflection to establish the 
material's ability to reflect, and the index of refraction to control the amount of bent light when it travels 
through substances such as glass. 

6.1 Editing a Layered Material 

Materials can be grouped together in a single layer. Each material within the layer can be activated to display it on 
the objects to which it is applied. This can be helpful when wanting to show a customer a product with difference 
materials. 
For example, you can show a car with different colored paint without having to adjust the material properties 
individually. 

1. Open messerschmitt.rh and double-click the MESmess material in the Materials list. 

       
2. Note that it is definitely the light blue paint color on the model and close the dialog by clicking OK. 
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3. Duplicate the material three times and modify the color and name of each new material. Here we have 
modified the colors and names to red, green, and blue. 

 
4. Open the MESmess material again and select Layered in the Shading field. The material’s thumbnail 

displays an L in the Materials list. 

  
Layered material properties              Layered material thumbnail 
 

5. Select the new MESmess red material from the drop down list. The material is added to the layer and the 
material thumbnail displays the most recently selected material. 

Note 
Pick can be used to select a material using the viewport rather than a list. This is useful in scenes where the 
list of selectable materials is extremely long or where the names are meaningless. 
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6. Continue adding the other new materials below the red material. 

 
You are able to continue adding materials to the layer for as many materials there are that belong to the 
scene. You can also use the Amount fields to control the percentage of material that displays on its 
related objects. Note that whichever material layer has the higher percentage is applied exclusively to the 
objects. 

7. Click Activate to activate each material within the layer to the model. Note that the activated material is 
the only one that is displayed on its related objects. 

      

 
8. As you activate each material, create a model view for the new color. You can then simply click each 

model view to present the car in different colors with a minimum of activity. 
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6.2 Editing an HDR Material 

HDR materials are supported in SAP 3D Visual Enterprise Author. The HDR material type and its various 
properties can be controlled including the material’s ambience, reflection, and refraction. 

1. Choose the HDR Realtime display renderer. 
2. Select HDR Material in the Shading field of the Basic tab page for the MESmess material. The material’s 

thumbnail displays an H. 

  
Layered material properties              Layered material thumbnail 

3. Experiment with selecting the different types of HDR materials and changing their properties. Here we 
choose the High Gloss Paint material type and modify the matte and coating colors. 
 

  
High Gloss Paint material type         High Gloss Paint viewport display 

4. Select the DirectX display renderer again in preparation for the next exercises. 
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7 Appling Materials to Object Elements 
All objects are a collection of elements such as vertices, polygons (faces), and surfaces (coplanar faces). This 
group of elements is called a mesh, and using the Mesh select toolbar, can be used to apply materials to singular 
object components. Object meshes can also be deleted. 

1. Open the Bevel gear assembly model and note the object hierarchy in the Scene tree. 

 
2. Display the Mesh Select toolbar. 

 
3. Select two objects in that scene, right-click in the viewport and choose Tools > Collapse Hierarchy. The 

objects are merged into one. 

   
Single objects selected         Scene tree objects merged 

4. Click Select separate mesh element  on the toolbar and click one of the collapsed objects.The original 
individual mesh object is selected despite both mesh elements effectively being a single object. 
The object node is not highlighted in the Scene tree because not all objects belonging to the node are 
selected. 
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5. Drag the Copper Bump material onto the selected object and deselect the object. 
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8 Textures and UV Mapping 
Texture maps are a way of adding surface texture, detail, and color to models - defining the material’s 
appearance. 
Objects must have UV coordinates in order to add textures (except reflection maps) to a material, or to prepare 
the model for other types of modification in SAP 3D Visual Enterprise Author. For example, to simulate global 
illumination using the Realight tool. 
UV coordinates are not present in raw CAD data, therefore, many models must be mapped to find the UVs and 
place them on the model’s geometry. If a model has UV coordinates, a UV tab is displayed in the model’s Object 
Properties window showing the layout of the mapped polygons. 
Once a model is mapped, the UV’s can be relaxed to minimize distortion, then packed to arrange UVs in a 
structured manner. 
 

 

8.1 Applying Texture Maps 

1. Open the Reallight Transmission.rh and save it with _UVs appended to the end. 
2. Zoom into the outer casing object. 
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3. Double-click the case etc material in the Scene tree or Materials list and click the Maps tab page to view 
all the available texture maps and the Diffuse map’s current texture. 

 
 

4. Click the Diffuse map and click Remove. The texture is removed from the material’s diffuse map. 

 

Maps tab page               Removed texture 
 

5. Click Browse and locate an image file to apply as a texture to the map.  
The default folder in which material files are stored is C:\Program Files\Right 

Hemisphere\Visual Enterprise Author(version)\Textures.  
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6. Click Open to apply the texture to the Diffuse map. The edited material is displayed on the model. Here 
we use the CactusPad image. 

 

  
7. Remove this texture and click Close. 
8. Drag a material from the Materials tab page. Here we drag the Carbon Fibre.rhm onto the outer casing 

object. 

 
Materials tab page 

 
Newly applied material  
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9. Note the new material is reflected in the Materials folder and Materials list. 

  
Materials folder       Materials list 

10. Double-click the object in the workspace to display the Object Properties window. 
11. Click the UV tab page. You can see one of the models’ curved surfaces represented by its UVs, covering 

the material’s texture at the scale defined in the material properties. 

 
12. Double-click the ‘case etc’ material in the Scene tree or Materials list to display the Material Properties 

dialog. We now have two dialogs open between which we will switch to view and manipulate the material 
UVs. 

13. Click the Maps tab to display the casing’s material properties.  
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14. Click the Information tab in the Material Properties dialog to see information relating to the map, 
including its lighting levels, and number of times the texture is repeated across the UVs. 
 

 
 

15. Use the mouse buttons or navigation tools from within the Object Properties dialog to see how the 
pattern is mapped onto the casing. For example, use the right mouse button to zoom into and out from 
the UVs. 
 

  

UVs best fit           UVs zoomed in 
 

16. Consider the UV mapping. In effect, the carbon fibre pattern is being mapped onto the casing surfaces 
using the models UV coordinate system. U being the width and the V being the height. The squares and 
triangles represent the curved surfaces of the casing. 

17. Consider the Maps tab page on the Materials Properties window, and see how the UV scale is 10 by 10. 
This means that the pattern is being tiled 10 times in the U, and 10 times in the V.  
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18. Modify the UV scale to 20 by 20 and note the change in the UVs and the model. As you can see the 
pattern is now being mapped 20 by 20. 

  

UVs scaled to 20 
19. Modify the UV scale to 5 by 5 and note the change in the UVs and the model. 

  

UVs scaled to 5  
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8.2 Understanding Map Types 

1. Create a primitive in a new scene. 
2. Open the default material properties and browse for a texture to apply to the diffuse map. 
3. Move and zoom the model to see the newly applied textures in more detail. Here we have chosen the 

BricksLgMortar.jpg image to use as the texture. 

 
4. Keep the Material Properties window open, remove the texture, and then add that same texture to each 

of the map types using the drop down list. 

 
5. Note how the same texture is reflected differently for each map type. For example, if you add an image of 

sunset to the reflection map, the material reflects the sunset on its surface. Here, we have applied the 
same texture to a number of maps. 

  

Ambient map           Ambient Occlusion map 

  
Bump map              Opacity map 
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Reflection map            Self illumination map 

6. Use the Amount field to modify the ‘strength’ of the individual channels. For example, the luminescence 
of the Self Illumination map or the bumpiness of the Bump map. 
Experiment with the offsets, scaling, and angle apply texture blending. 

7. The Materials Properties window reflects the material when it is selected in the Materials folder and Scene 
tree. 

8.3 Mapping a Model 

1. Open Automotive Crossmember Example with Steps.rh and double-click any of the model’s 
objects. Note that there is no UV tab and therefore there are no UV coordinates with which to add 
textures. 

 
2. Open the UV Mapping toolbar. 

 
3. Close the object properties dialog, ensure no objects are selected, and then click Map, Relax and Pack 

 on the toolbar. The window displays the progress of polygons being mapped into UV space and the 
resulting UV's being packed. 
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If you have an object selected and use the UV mapping tools, the process only operates on the selected 
object. 

 
4. Double-click an object again and view the new UV’s. 

 
5. Experiment with changing the UV mapping settings and remapping, relaxing, and packing the UVs. 

 

8.4 Exporting Textures 

Textures can be preserved with models when you save into the .rh format. For example, if a model has a material 
that uses a reflection map, and you want the model to retain that texture with the material. 
You can save the model with links to the location of the texture maps (image files), or you can embed the image 
files within the .rh file. This is helpful when using 3D models within Microsoft Office applications such as 
PowerPoint and MS Word; the image files can be located externally or from within the 3D model itself. 

1. Choose File > Save As on the menu bar. 
2. Click Settings and click the Texture Maps tab page. 
3. Clear the ‘Include textures in 3D file’ option and note how the available save options change. For example, 

you can select to save links only certain texture formats, and you can convert texture files to another file 
type. 
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If you save an .rh file that already has embedded textures, without selecting the Include textures to 3D 
file option, the embedded textures are not saved. 
The process of exporting and saving .rh files is powerful and complex. For more information, see the 
SAP 3D Visual Enterprise Author help.  
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9 Applying Realighting 
Realighting is a process that makes models appear more realistic. It does this by simulating global illumination 
and self-shadowing. Models are rendered as if they are surrounded by a dome of light (ambient light), and the 
more accessible a point is to the light, the more light it receives. For example, a crevice will be darker than an 
exterior surface. 
Models usually require UV mapping to have realighting applied. However, certain settings can be used to apply 
realighting without needing UV mapping, such as storing the ambient occlusion as vertex colors. We discuss this 
below. 
Realighting is very useful for rendering models that lack texture, surface depth (bump), and lighting, etc. It 
functions better on static, rather than animated objects. 
Realighting doubles the file size. This may inhibit performance and affect downstream materials functions 
including Realight rendering and raytracing. There are alternatives to using the Realight tool if experiencing 
difficulties with inverted normals and or faces. For more information, see the SAP 3D Visual Enterprise Author 
help. 

1. Open Landing_Gear2.rh in Solid mode and save it with _realighting appended to the end. 

2. Display the UV Mapping and Realight  toolbars. 
3. Map, relax and pack UVs for the model then click Realight. The Realight Settings window is displayed 

 
 

4. Click OK to render the texture maps with the default settings. The realight progress is displayed while the 
model is processed. This process may take some time depending on the size of the model. 

 
5. Click OK when the process is complete. 
6. Zoom into the model and consider the improved lighting. 
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Before realighting         After realighting 

9.1 Realight Settings 

Many settings can be used to render models using the Realight tool. Here, we describe just a few. 

Setting Description 

Store as vertex colors Stores the ambient occlusion as vertex colors and does not required UV 
coordinates 

Store as texture maps Stores the ambient occlusion as texture maps, and is good for smooth 
surface and low polygon density objects. 

Rays per sample The number of per vertex or per sub-pixel surface samples. That is, the rays 
that are cast from each of the surface vertices in vertex color mode, or sub-
pixels in texture maps mode.  

Brightness Determines the level of brightness of the ambient occlusion 

Outcome Used to select the manner in which maps are generated 

Map Mode Used to select the manner in which texture maps are blended with the base 
material 

Noise Applies white noise to the texture map 

Prefilter Applies color bleed around the polygon groups 

Use virtual ground plane Utilizes the virtual ground plane to calculate the illumination. Any rays cast 
from the bottom of the model collide with this plane to cast shadows on the 
model’s base. 

 ‘ 
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