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How to Design Excel Templates 

Applies To: SAP Disclosure Management 10.1 SP7 and higher 

SAP Disclosure Management provides three ways to design Word tables automatically 

refreshed from Data Cache: “No Templates”, “Word Templates” and “Excel Templates”. 

The “Excel Templates” method is the most user-friendly way to design Word tables in SAP DM 

reports. But there are a few design restrictions due to MS Excel limitations: 

▪ Non-integer Font Size (for instance 7.5) are not supported by Excel 

▪ The thickness of Excel tables’ borders is not as rich as in Word and it is not possible to 

underline whole paragraph in cells 

▪ The cells’ margins are predefined to 0.4 mm as Excel only defines indentation 

▪ Table size width in percent is not stable in all platforms (required for HTML EDGARization) 

▪ You may need to adjust the height of a row in Excel so that in Word, a text label properly 

fits in one cell or a table fits in one page 

Warning: As of current version 10.1 Stack 1101 of DM, Excel Templates do not support Right-

To-Left formatting (Hebrew, Arabic… languages) 

See the User’s guide of SAP Disclosure Management and the SAP Note 1809022 to check the 

Whitelist of all supported Excel properties. 

The Excel templates can display formatted numbers like amounts, percentages, currency, dates, 

and so on… Numbers are usually formatted with decimal tabs. 

Before you start 

Here is a check-list of actions to be performed in SAP Disclosure Management before you start 

implementing Excel Templates: 

Reduce the number of Word styles 

In the Web interface of SAP DM, go to Administration > System Configuration > Content 

Refresh > DO Not Use Structured Word Styles for "Excel Template" and check that the 

value of the setting is “No”. 

When this parameter is set to “No”, DM is supposed to apply the most recent behavior, i.e. the 

styles of the table are transferred from Excel to Word. For instance, if a style called “DM_Cell” 

exists in Excel to format the cells of the BIP range name, DM creates a Word style called with 

the same name “DM_Cell” to format the Excel Template based table in Word. This limits the 

number of created styles in a report. 

Adjust Word settings 

https://help.sap.com/viewer/6fda503523d6413597f5cd81be59fa8a/DM%20Stack%2011xx/en-US
https://launchpad.support.sap.com/#/notes/1809022
https://support.office.com/en-us/article/Create-or-delete-a-custom-number-format-78f2a361-936b-4c03-8772-09fab54be7f4#bm1
https://support.office.com/en-us/article/Create-or-delete-a-custom-number-format-78f2a361-936b-4c03-8772-09fab54be7f4#bm2
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To implement Excel Tables more accurately, open MS Word: 

▪ Go to Options > Advanced, tick the Display Bookmarks checkbox 

▪ In the Home tab of the Office ribbon, show Paragraph Marks by clicking on the  icon. 

Regional settings 

Because you may need to manipulate Decimal Tabs in Word, the Windows’ Regional Options 

of the desktop client (or the Citrix client) should be adapted to the language of the report. 

For instance, if your report is in French, you cannot properly render decimal tabs in your Word 

tables if the regional Format is English. Word would try to decimal align numbers on the point 

while they should be aligned on the comma. 

If you run on Windows desktop, open the Control Panel then click Region and select the 

Format language in the first tab. 

If you run on Citrix servers, implement as many published applications as languages of your 

reports, where logon scripts are adapted to set regional options, Internet Explorer and MS 

Office language. Alternately, you can publish only one Citrix application (usually in English by 

default) and then implement a Powershell script to adapt the Language settings. 

Apply Word Template 

To avoid discrepancies between the design of the Word chapters and the generated report, all 

chapters should NOT start from the default version 0 which applies local server template. 

If you start Word chapters from scratch (version 0): 

▪ For every chapter, upload empty Word document (for instance New.docx) created from 

the main Word template of the report, with Comment "Applied Word template from empty 

chapter", so that you can start the design from version 1. 

If your Word chapters already contain some content: 

Then you need to correct the content of every Word chapter: 

▪ Edit the current chapter and backup existing data links references: click the 

Objects icon in the SAP Disclosure Management tab, select all rows (if any) and copy-paste 

them into an Excel worksheet. Click Discard Changes. 

▪ Upload empty Word document (for instance New.docx) created from the main Word 

template of the report, with Comment "Applied Word template from empty chapter" 

▪ Edit the new empty chapter (check-out) 

▪ Switch off Track Change mode 

▪ Show Styles 

▪ Go to the Revisions Tab of the DM web interface, download and open previous revision 
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▪ Copy-Paste (using default option) the previous content into the new empty chapter being 

edited. 

▪ Review and compare content and styles: you notice that the formatting of all Word objects 

is kept and all used styles from the previous revision are restored. The formatting rules is 

defined in Appendix 1. 

▪ All Datalinks are lost in the new document. You will recreate them by adding new Excel 

Template-based tables (see section: Guidelines for adding and adjusting Excel Template. 

Use the backup of the data link information from the Excel worksheet. 

▪ Delete all DOC_TBL_... bookmarks one by one. They are no more useful. 

▪ Apply Changes (check-in), keep the chapter edited and comment "Content copied from 

previous revision" 

BIP_WordTableDef.doc document 

The BIP_WordTableDef.doc file contains all Word Templates. But it is also used in background 

for the building of Excel Template tables. 

It is recommended uploading the empty Word document used for the initialization of Word 

chapters, so that the report is not later polluted by other Word styles. 

Open the new.docx file and save it in Word 97-2003 format. Rename it to 

BIP_WordTableDef.doc. 

Go to Administration > Content Refresh, then upload the BIP_WordTableDef.doc file. 

Guidelines for configuring Data Cache 

Edit Data Cache chapter (check-out). For every input BIP table of the Word chapter (Go To 

(CTRL+G) BIP table or use the selection box to select BIP range, then follow this check-list: 

Decimal Tabs 

Use a “Custom Format” pattern in every Excel numerical cell, so that all numbers are properly 

aligned with a decimal tab in Word. An Excel number format can have up to four sections of 

code, separated by semicolons. Those code sections define the format for positive numbers, 

negative numbers, zero values, and text, in that order. 

<POSITIVE>;<NEGATIVE>;<ZERO>;<TEXT> 

The <TEXT> part is not required for configuring DM Data Cache. 

Here are standard patterns that you can use to simulate decimal tab in Excel: 

To display Use this code 

Values without Decimals _(#,##0_);(#,##0);_("-"_) 
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To display Use this code 

Values with Decimals _(#,##0.00##_);(#,##0.00##);_("-"_) 

Percentage without Decimals _(#,##0%_);(#,##0)%;_("-"_) 

Percentage with Decimals _(#,##0.00##%_);(#,##0.00##)%;_("-"_) 

Blanked Values without Decimals _(# ### ##0_);(# ### ##0);_("..."_) 

Note: in case that you use regional setting different from English, you may need to adapt the 

custom format to locale. For instance, here are the same patterns to apply for French locale: 

To display Use this code 

Valeur sans Décimales _(# ##0_);(# ##0);_("-"_) 

Valeur avec Décimales _(# ##0,00##_);(# ##0,00##);_("-"_) 

Pourcentage sans Décimales _(# ##0%_);(# ##0)%;_("-"_) 

Pourcentage avec Décimales _(# ##0,00##%_);(# ##0,00##)%;_("-"_) 

Valeur effacée sans Décimale _(# ### ##0_);(# ### ##0);_("..."_) 

Horizontal Alignment 

The alignment of the cells should be set explicitly. Especially, you need to explicitly right align 

all numerical cells content, because Excel automatically shows numerical content right 

aligned while Word just manipulates alphanumerical string. If no explicit alignment has been 

set, the converter will align to left all numbers in the Word table. 

Vertical Alignment 

All cells in the same row should be consistently aligned. 

Row Height 

The rows’ height should be set so that all text content (configured or not with Wrap Text) 

properly fit in the cell. You cannot adjust later the row height from Word. 

Wrap Text 

DO NOT configure “Wrap Text” on numerical cells. 

Merged Cells 

The SAP Disclosure Management converter supports vertical and horizontal merged cells, if 

they are properly set in the table. 

Grouped Rows or Columns 

DO NOT group row or columns. Otherwise, SAP Disclosure Management might not bring any 

content in the preview area of the Manage Datalink window and in the Word table. 
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Hidden Rows or Columns 

If you use the hide feature of Excel for rows and cells, the hidden rows or columns will not be 

transferred to the resulting Word table. The layout of the table will look the same as in the 

viewable Excel document. No hidden data is transferred into the Word table. 

Superscripts 

All cells that contain superscript content should be text-formatted. 

There are two common cases of superscript to handle for financial reporting: 

1. A footnote is defined for the whole row or column, so the user should include the 

superscript at the end of a hardcoded text label. There is no special action to perform 

except adding the digit note, format its font in superscript and format the cell as a text. 

2. A footnote is defined for a numerical value. In this case, you should not include the 

superscript at the end of the value because the cell is number-formatted and it might 

impact the alignment of amounts. Manage a column at the right of the amounts 

including text formatted left-aligned cells to host the superscript information. The 

right margin for values will then be removed in Word so that the subscripted digit 

appears stick to the number. 

BIP Range Names 

In the data cache chapter, select the Formulas tab of the Excel ribbon, then click the Name 

Manager icon. Check that the Scope of every BIP range name is “Workbook”, otherwise it will 

not be listed among the Data Providers. If the Scope is a worksheet name; you must delete and 

re-create the BIP range name. 

Finally, Apply Changes in the Data Cache chapter and Edit (check-in) with Comment. 

Guidelines for adding and adjusting Excel Template-

based tables 

For each Table in the Word chapter: 

Add Table with Datalink 

Insert Excel Template-based-Table by clicking the Create > Table icon of the SAP Disclosure 

Management tab. 
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In the “Manage Datalink” popup window, click the  New button 

Choose the Datasource in the selection box, then click the  button. 

Select the  Filter button to restrict the selection to the Data Cache of the current period, 

then select the BriefingBook in the list box of BIP ranges. 

Select BriefingBook for previewing, then tick the checkbox corresponding to the BIP range. 

Click OK. 

A new line is added to the “Manage Datalink” list box. Up right to the list box, there is a selection 

box - choose Excel Template. 

Click OK. 

Then, the formatted table is added to the Word document. 

Table Width 

Right-Click > Table Properties. In the Table tab, set the Preferred width around 100 % in 

percent. Then switch back to the corresponding value in centimeters or inches. 

Adjustable Column Width 

If the ruler is not displayed on top of the Edit area of Word, go to the View tab of the MS Word 

ribbon and tick the Ruler checkbox. 

Adjust the columns’ width through the Ruler using the mouse with the <Alt> key pressed. 

Update the column width so that all amount columns have the same size or the label texts are 

properly wrapped as much as possible. 

Select the table and click the Show Detail icon. Alternately, you can click the Edit objects icon. 

Tick the Adjustable column width check box, so that the SAP DM converter keeps all 

customized columns width of the table after refresh. 

The Adjustable Row Height is useless in the case of Excel Templates. If needed, adjust the 

height of a row from Excel, apply Changes in the Data Cache chapter and refresh Word table. 

Customize Decimal Tabs 

After adjusting the columns’ width, you may need to adjust Decimal Tabs through the Ruler 

using the mouse with the <Alt> key pressed for each group of numerical data (amounts, 

percentage, prices...). Manage a right margin so that the numbers are aligned with text headers 

as much as possible and there is enough size for closing bracket of negative numbers. 

After refreshing the tables of the Word chapter, the adjusted decimal tabs will stay the same. 
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Note: The format of negative and zero in Word table is defined by the Locale setting of the 

report (in the web interface of DM, see Settings > Manage Reports and Edit report) 

Content Refresh 

Select the Word Table then click the Refresh icon > Object from the SAP Disclosure 

Management tab. The layout of the table should stay unchanged. You can alternately save  in 

the repository (check-in) the chapter and launch Server Content Refresh from the web interface; 

go to Report > General then select a chapter and the Content Refresh tab. Push the Start 

refresh button. 

Finally, Apply Changes in the Word chapter and Close (check-in) with Comment. 
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Appendix 1 

General formatting rules noticed with MS Word 2010 to 2016 during normal copy-paste of 

content (default behavior when using <Ctrl>+C and <Ctrl>+V) are described below: 

▪ If the style of the copied text is set at the template’s level of the recipient Word file (not 

attached anymore to normal.dotm), the style of the recipient Word file applies 

▪ If the style of the copied text is only defined at the recipient Word file (not attached 

anymore to normal.dotm), the style of the source file applies 

▪ If the style of the copied text does not exist in the recipient Word file, it is copied to the 

recipient file and applied with the text 

As you can see, the rule is not simple and might be different depending on future versions of 

Word. But overall, the formatting together with the Word styles is kept. 


