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How To: XBRL Tagging in Word and Excel 

SAP Disclosure Management How To Series 

Applies To: SAP Disclosure Management 10.1 SP0 and higher 

RECOMMANDED SETTINGS 

Always configure Word to display paragraph marks and other hidden formatting symbols. In the 

Home tab of the Word ribbon, activate the  icon. 
 
Also configure Word to display Bookmarks. Go to File > Options > Advanced. In the “Show 
document content” section, tick the Show bookmarks check box. 
 

 
 
Then, all XBRL tags in Word will appear inside dark grey brackets […]. 
 
Note: You can work with multiple MS Word and Excel sessions, but only one MS Word and one 
MS Excel at a time with the DM XBRL Mapper started. 

BEST PRACTICES 

1. DIFFERENT WAYS OF TAGGING 

In MS Excel, select a cell or a group of cells to tag. 
 
In MS Word, select the whole text area for the tagging of the concept. Then click inside the area 
for the tagging of the context, the unit, the dimension member or the format.  
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In the Mapping Area located in the left side of Excel or Word, the standard way to assign XBRL 
Concept, XBRL Context, XBRL Unit and XBRL Dimension Member to text-block is to double-click 
the label of the entry in the tree-view of the mapping area. 
 

 
 
Do not tick the check box of the related element, except if: 
▪ it is not yet tagged 
▪ you want to remove existing tagging on that element 
 

2. [EXCEL] MOVE TAGGED CELLS 

The DM Mapper should not be launched while: 
▪ Moving cells before tagged cells 
▪ Inserting rows, columns or cells before tagged cells 
 
Otherwise, you might introduce discrepancies between the in-memory mapping and the tagging 
stored in the Excel chapter. 
 
Conditional formatting (green and yellow highlighting) should be deleted after inserting row or 
column or cell just before tagged cell. 
 

3. [EXCEL] HIDDEN CELLS AND IGNORED ROWS 

If table cells are tagged in Excel but not retrieved in the Word document, then the SAP Disclosure 
Management iXBRL Mapping Creation will write all missing tags in Word in the standard 
<ix:hidden> section of the iXBRL instance report. 
 
Common mistakes of the end-users are: 
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▪ to tag cells contained in hidden row or columns while tagging surrounding area, then retrieve 
the table in Word using “Excel Templates” 

▪ to tag cells that are ignored in the formatting of the table in Word using “Word templates” 
 
So, you should check that all cells tagged in the Data Cache are properly disclosed in the Word 
report, which is the source of the Inline XBRL Instance document. 
 

4. [WORD] SEPARATORS BETWEEN TAGS 

During tagging, you should leave at least one separator character in the Word document (space 
or paragraph character) between two contiguous or nested tagged text blocks. Otherwise, Word 
might mix the content of the tags. After tagging, it is possible to remove additional character. 
 
Special case: you can assign multiple tags to the same text block, provided that you follow the 
following procedure: 
▪ Show Bookmarks in Word (see section RECOMMANDED SETTINGS) 
▪ Tag a first time the text-block completely (concept + context + possibly unit, dimension and 

format) 
▪ Add a space separator (or any special character) at the beginning and at the end of the text 

block inside the brackets of the bookmark 
▪ Tag inside the separators a second time the text-block completely (concept + context + 

possibly unit, dimension and format) so you are sure that the second tag is nested in the first. 

 
▪ You can tag as many times as you need the text block that way… 
▪ Finally, remove all spaces (or special characters) added for the tagging of the nested tags. 
 

5. [WORD] LAST PARAGRAPH CHARACTER IN INLINE XBRL 

TEXT BLOCK TAGGING 
When tagging Word text blocks for inline XBRL (iXBRL) publishing, always include the paragraph 
character at the end of the last paragraph, otherwise this paragraph will be missing in the iXBRL 
tag during generation of the XHTML instance document. 
 
Example: 

 
 
Example: 
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Example: 

 
 

TABLE TEXT BLOCK TAGGING 
For US SEC reporting, it is recommended to tag every table this way: 
▪ Select the introduction paragraph - if any before the whole table - when tagging table text 

block (Level III). This can be a section title or a sentence. 
▪ To avoid issues with the management of Inline XBRL continuation tags <ix:continuation>, 

select the whole table and preferably the paragraph underneath when tagging table text 
block (Level III) or the end of disclosure text block (Level I) or the end of policy text block 
(Level II). 

 
Example: 

 
 
The above highlighted area in green color shows the table text block tag including the 
introduction paragraph and the paragraph symbol underneath the table. 
 
If there are table footnotes, they should be part of the Table Text Block tag including the last 
paragraph character. 
 

6. [WORD] REFRESH DATA LINKS 

For performance reasons, it is recommended to refresh or add data-linked table in Word 
document using the SAP DM client BEFORE you launch the Word DM Mapper. All values tagged 
from Excel will then automatically appear tagged in Word. 
 

7. [WORD] BOTTOM-UP TAGGING 

As much as possible, start tagging text blocks from the nested smallest blocks to the container 
blocks until you reach the largest block. 
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For instance, when preparing US SEC reporting, tag each disclosure one by one in Word chapter: 
1) Refresh the data-linked tables tagged in Excel using the SAP DM client 
2) Launch the Word DM Mapper for the tagging of text blocks: 

a. Start with the tagging of Level IV narratives if any 
b. Then tag the Level III table text blocks if any 
c. Then tag the Level II accounting policies text blocks if any 
d. Finally, tag the Level I disclosure text block. 

 
If you tag from top to down i.e., first the largest then the nested text blocks (Level I to Level III 
text block tagging in the case of the US SEC), you might change the tagging of the current tag but 
also all the parent tags at one time. As this multi-level mode cannot be changed in the current 
version, you might not be able to complete text-block tagging properly. 
 

8. [WORD] TOP-DOWN UNTAGGING / UPDATING TAGS 

Warning: selecting nested tag in Word makes you multi-select the tag together with all parent 
tags in read-mode and select only the tag in write-mode. 
 
If you want to remove one nested tag, do not use the “Remove Mapping” button or contextual 
menu that might delete the current tag together with all parent tags. Rather put the cursor inside 
the tag, excluding children tags, then double-click the corresponding element in the taxonomy 
tree-view. The SAP DM Mapper will ask to remove mapping. Click OK. 
 
Updating one nested tag means changing the Context, the Unit, the Dimension Member or the 
Format. Click inside the tag, then double click the label of the check box, or set the new format in 
selection box. 
 

9. [WORD] CHECK COLOR CODING 

When tagging a chapter, please check that the color coding stays consistent. It should look as 
follows: 
 

Color Nesting Level Tagging Order US SEC Level* 

Green 0 Last I 

Blue 1 1st or 2nd or 3rd II or III or IV 
Purple 2 1st or 2nd III or IV 

Grey 3 1st IV 
(*) US SEC Levels I, II and III correspond to text block tagging, Level IV corresponds to detailed tagging. 

 
For US SEC reporting, the first tagged values correspond to tags automatically transferred from 
Excel to Word (through tables, formula fields or floating fields) and narratives tagged in Word. 
  
Example: 
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Please note that the colors depend on the nesting level, not on the US SEC level… 
 
Warning: with the Word DM Mapper, the colors are not refreshed on the fly. You should 
regularly click the “Disable / Enable Highlighting” or the “Resolve incidents” button to review 
color coding. 
 
If the color-coding does not stay consistent (for instance, same level tables have different 
colors…) in Word after refreshing highlighting, you should discard all recent changes and come 
back to the latest correct revision. 
 

10. [WORD] SPLIT DISCLOSURES INTO SEVERAL CHAPTERS 

You MUST organize Word chapters not to include too many XBRL tags. Typically, define one 
chapter per Core Financial Statement and Disclosure. Otherwise, you might experience very long 
response time in Word when editing chapter with the Word DM Mapper launched. 
 

11. [WORD] REFRESH TABLES BEFORE OPENING DM MAPPER 

It is recommended first refreshing content of Word chapters BEFORE launching the DM Mapper 
or opening taxonomy in Word. 
 

12. RESOLVE INCIDENTS 

It is recommended clicking regularly the “Resolve Incidents” button, especially after refresh of 
Word tables (through Excel Templates, No templates, Word templates) or Formula Fields or 
Floating Fields from the Data Cache. 
 

Tagged 1st in Excel 

Tagged 1st in Word 

Tagged 2nd in Word 

Tagged 3rd in Word 

Tagged 4th in Word 
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13. [EXCEL] TAGGING OF DIMENSION MEMBERS 

The order of tagging members in the Dimensions tab of the DM Mapper is very important in the 
case of 2 dimensions or more tables. The couple of dimension axis and member is recorded in 
the tag in the reverse order of the tagging. For instance: 
 

 
 
If you tag the Retained earnings member of the Component of equity dimension before the 
Increase (decrease) due to application of IFRS 15 member of the Retrospective application and 
restatement dimension, then the dimensional tagging will be recorded this way: 
ifrs-full:RetrospectiveApplicationAndRetrospectiveRestatementAxis|ifrs-

full:IncreaseDecreaseDueToApplicationOfIFRS15Member||ifrs-

full:ComponentsOfEquityAxis|ifrs-full:RetainedEarningsMember 

where the latest tagged dimension appears first in the list separated by double-pipe symbol(s). 
 
Always apply the same order of tagging between axis, otherwise you might face validation errors 
due to duplicate XBRL contexts where same dimension axis and members are disclosed in 
different order. 
 

14. [WORD] DIMENSIONAL AND FORMAT TAGGING 

Warning: in the current version 10.1 Stack 1902 of SAP Disclosure Management, the tagging of 
the dimension member or the format of nested tag might also update the tagging of parent facts. 

The workaround for the tagging of dimension members is to temporarily remove the tagging of 
all parent facts, then retag bottom-up. 
 

15. [EXCEL] MULTIPLE CONTEXTS TAGGING 

When selecting multiple cells tagged with both Instant and Duration concepts, all XBRL Context 
are open for tagging. They are not disabled for tagging to allow more rapid tagging. So, it is your 
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responsibility not to tag context which definition of the period does not match the periodType 
attribute of selected concepts. Otherwise, you might get validation errors due to incorrect 
context used in XBRL facts. 
 

16. [WORD] SPECIAL CASES 

Since SAP Disclosure Management 10.1 Stack 1901, you can tag separate text blocks with the 
same concept, context and dimension. This allows the mapping of non-contiguous areas inside 
one single tag – or excluding areas from tags. 
 
This is useful to exclude text area not properly managed by the Word DM Mapper, or to support 
larger text blocks possibly distributed among multiple chapters. 
 

17. IN CASE OF EXCEPTION 

In case of error / exception of the DM Mapper during tagging, you should discard changes and 
come back to the latest consistent revision. 
 

18. SAVE REGULARLY 

While tagging, save the chapter regularly. Click “Apply Changes”, then tick the “Edit” radio 
button if you have not finished the mapping process. 

UNSUPPORTED FEATURES 

Multi selection tagging is currently not supported in Word i.e., you cannot select multiple text 
blocks already tagged with concepts and apply the same XBRL Context and/or XBRL Unit and/or 
Dimension Member and/or Format. 
 
Multi-level mode is currently not supported in Word i.e., you cannot select nested text block tag 
and decide whether you assign XBRL Context and/or XBRL Unit and/or Dimension Member 
and/or Format to the nested tag only or the nested tag including the parent tags. 
 
Especially, you cannot tag Dimension Member and/or Format to text-block nested inside parent 
text-block already tagged with Dimension Member and/or Format. You might need to retag 
parent text-block and use the Mapping Overview to check tagging in Word. 

REVIEW TAGGING 

19. 2-WAYS SYNCHRONIZATION 

DOCUMENT TO MAPPING AREA 
With the Excel or the Word DM Mapper, you can click one tags or select several tags inside the 
document to easily locate the corresponding node(s) of the Tree View or the value inside the 
Mapping Area: XBRL Concept, Context, Unit or Dimension Member or Format 
 
Attention: in the Mapping Overview tab, the rows corresponding to the selected tags are 
highlighted in red color, but the focus is not put on any row, so you might have to scroll the table 



 

9 

until you find it. You can sort the table by clicking the one header to find the row more quickly, 
each row corresponding to one tag 
 

MAPPING AREA TO DOCUMENT 
With the Excel DM Mapper launched, you can select any node in the tree view or row of the 
Mapping Overview table, then the corresponding cells will be highlighted in the current 
worksheet and the focus is put on the first tag. 
 
With the Excel DM Mapper launched, you can select any node of the tree view or row of the 
Mapping Overview table, then only the first corresponding text block tag is highlighted and the 
focus is put on it inside the Word chapter. 
 

20. SCROLLING 

While the cursor is over the Mapping Area of the DM Mapper, the use of the scroll wheel of the 
mouse will also cause the document to scroll up or down. 
 

21. INTERNAL TAGGING 

The tags are stored on-the-fly inside the Excel and Word chapters. Then they are consolidated in 
the database when the user applies changes. If you have recent version of SAP DM, the upload of 
document allows proper storage of the XBRL tags in the database. 
 

EXCEL 
Go to File > Options then Customize Ribbon. In the right area, tick the Developer checkbox to 
activate the Developer tab in the Office Ribbon. 
Go to the Developer tab then click the Visual Basic icon. In the Project window, select the 
DM_Variables sheet. In the Properties window, change the Visible property to -1 - 
xlSheetVisible. 
 
You can now access the DM_Variables sheet to review the internal Excel tagging. Each tag 
corresponds to a row of the table. Especially, in the Reference column, check that there is no 
#REF! Excel error, which might be caused by deleted tagged cell. 
 
Warning: Never modify the content of the table in the DM_Variables worksheet while the DM 
XBRL Mapper is launched or the XBRL taxonomy is loaded in Excel. This might cause an exception 
of the Excel Add-in. 
 
The highlighting of tagged cells (green color when the tagging is complete, yellow otherwise) is 
managed through Conditional Formatting. Select a range of tagged cells in Excel, then go to 
Home > Conditional Formatting > Manage Rules to review or possibly remove improper rules. 
 
Alternately, you can try to fix highlighting problems by clicking the Resolve Incident button in the 
DM XBRL Mapper tab of the Ribbon. 
 
In the case of Inline XBRL, all Excel tags not retrieved in Word chapters (because there is no 
datalink to Briefing Book or the tagged cells have been hidden) will appear in the <ix:hidden> 
section of the generated instance document. 
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WORD 
There is one Word bookmark for every XBRL block tagged in Word. All those bookmarks are 
named DM_MAP_(GUID), the GUID (Global Unique Identifier) being a 128-bit unique reference 
number formatted in hexadecimal. 
 
In Word, you can review the DM_MAP_... bookmarks by selecting the Insert tab in the Office 
Ribbon then click the Bookmark icon: 

 
 
The description of all XBRL tags (concept, context, unit, dimension, format) is stored in Word 
variable called DM_MAPPING000 
 
If “Data Ambiguous” errors related to DM_MAP… tags are logged in the generation log or in the 
XBRL - Template - Consistency Validation.xlsx file, simply copy the DM_MAP_(GUID) reference 
and paste it in the Bookmark name entry field of the Bookmark manager (see above 
screenshot), then click the Go To button to identify every duplicate tag. 
 
If DM_MAP_(GUID) references logged in the validation report do not exist, run Resolve Incident 
to refresh the XBRL mapping, or search for legacy mapping inside Word template of the report. 
Remove all XBRL tags from Word template by using the Word macro defined in the next section. 
 
If the Word DM XBRL Mapper get stuck when selecting or parsing existing tagged block at the 
opening of the chapter, kill the Word process, undo check-out and reopen the Word chapter 
without launching the DM XBRL Mapper. You can simply remove XBRL tag from Word chapter by 
deleting the corresponding bookmark, then Apply Changes. 

RESET TAGGING 

EXCEL 
Go to File > Options then Customize Ribbon. In the right area, tick the Developer checkbox to 
activate the Developer tab in the Office Ribbon. 
Go to the Developer tab then click the Visual Basic icon. In the Project window, select the 
DM_Variables sheet. In the Properties window, change the Visible property to -1 - 
xlSheetVisible. 
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Then, you can simply right-click the DM_Variables worksheet and delete it. Finally Apply 
Changes in your chapter. 
 
Warning: Never remove the DM_Variables worksheet while the DM XBRL Mapper is launched or 
the XBRL taxonomy is loaded. This might cause an exception of the Excel Add-in. 
 

WORD 
Go to the View tab of Word and click Macros > View Macros. In the Macro name field, enter: 
RemoveXBRLMapping and click the Create button. Copy-paste the following code: 
 
Sub RemoveXBRLMapping() 

'To delete XBRL tagging in a Word file 

Dim x As Long 

Dim objBookmark As Bookmark 

MsgBox ActiveDocument.Variables.Count 

For x = ActiveDocument.Variables.Count To 1 Step -1 

If Left(ActiveDocument.Variables(x).Name, 6) = "DM_MAP" Then 

MsgBox ActiveDocument.Variables(x).Name 

MsgBox ActiveDocument.Variables(x).Value 

ActiveDocument.Variables(x).Delete 

End If 

Next x 

For Each objBookmark In ActiveDocument.Bookmarks 

If Left(objBookmark.Name, 6) = "DM_MAP" Then 

objBookmark.Delete 

End If 

Next 

End Sub 

 
 
Close Microsoft Visual Basic for Application. Then, go to the View tab of Word and click Macros > 
View Macros. Select the RemoveXBRLMapping macro that have just been created, then click the 
Run button. 
 
This macro will erase all XBRL tags from current Word chapter. Finally, Apply Changes. 

FREQUENTLY ASKED QUESTIONS 

Does the DM XBRL Mapper support the following tagging methods / requirements: 
a) Continuation 

[EXCEL] N/A (Non applicable) 
[WORD] Yes. Separated text blocks can be tagged to compose one single fact, the text blocks 
are concatenated in the order of appearance in the Word report 

b) Multi-selection 
[EXCEL] Yes. It is possible to select any range of Excel cells and tag them with same concept, 
context, unit, dimension member or format. It is also possible to select non-contiguous cells 
by using the CTRL key and then, tag them. 
[WORD] No. It is currently not possible to select multiple text blocks and tag them to apply 
same context, unit, dimension member or format. 

c) Nested 
[EXCEL] N/A (Non applicable). Note that you cannot select part of Excel cell and tag it. But 
you can split cells, considering the restriction that 2 cells with different values should not be 
tagged with the same fact. That would cause “Data Ambiguous” error. 
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[WORD] Yes. Special color coding allows distinguishing several tags nested to one another. 
This is a requirement for US SEC (Level I to IV tagging) and ESEF reporting. 

c) Multi-level (see definition below) 
[EXCEL] N/A (Non applicable). 
[WORD] There is no switch in the Word DM XBRL Mapper to allow the tagging of context, 
unit, dimension member or format in the selected text block only or including all parent text 
blocks 

d) Overlapping 
[EXCEL] Yes. Thus, you can mix different tagging of concept, context, unit, dimension member 
or format in row, column or area. 
[Word] No. The tagged areas should be either distinct or nested to one another. 

e) Multiple tags 
[EXCEL] No. You cannot assign multiple tags to the same cell. 
[WORD] Yes. You can assign multiple tags to the same text block area, provided that all tags 
are nested to one another. See Word tagging best practices in section 4. 
 

What is multi-level? 
The multi-level mode applies to tagging in MS Word and means that: 
▪ you can review the tagging of the selected text block and all parents when clicking a text 

block 
▪ you can change the context, unit, dimension member or format of the current tag and all 

parents at one time 
If the multi-level is deactivated, then: 
▪ you can review the current tag only, independently from the parent tags 
▪ you can change the tagging of the context, unit, dimension member or format of the child 

text block individually 
Currently, the DM XBRL Mapper applies the multi-level mode without clearly being stated, which 
might be confusing. 
 

Is there any issue or recommendation when tagging text blocks with multi-column layout? 
No. 
 


