Appraisals

This document contains an Appraisal configuration Guide for TEM and LSO.

Document to setup the appraisal settings for TEM

IMG:
Training and Event Management
Recurring Activities
Appraisals
  Appraisal Conversion Program
  Form of Appraisal
  Edit Scales
  Edit Appraisals Catalog
  Set Up Control Parameters

Appraisals:

With this step you define the settings required for creating attendee and business event appraisals in Training and Event Management. These settings are automatically generated the first time you call the function.

Appraisal Conversion Program:

In this step, you can start the conversion program RHUMAPPR if it was not already run the first time the appraisal functions were used in the system. If it was already executed, a message to this effect is output.

Form of Appraisal:

A form of appraisal contains information on

- The name of the appraisers and appraisees (or objects appraised)
- Object types that are allowed as appraisers and appraisees (or objects appraised)
- Evaluations paths to create to-do lists for groups of objects (optional)

Example

By specifying an evaluation path, you can determine all the attendees of a business event, and prepare the appropriate business event appraisals. When you create a form of appraisal to be used with the appraisal type anonymous individual appraisal or anonymous multisource appraisal, make sure that the role name of the appraisers does not reveal their identity.

The forms of appraisal are also taken into account in the workflow Approving and Following Up an Appraisal (WS 10000105). The form of appraisal linked to the appraisal model on which the appraisal is based determines whether or not the approval process is triggered for the appraisal. For more information, refer to the SAP Library (HR - Human Resources -> PA - Personnel Management -> Personnel Development -> Workflow Scenarios on Personnel Development (PA-PD) -> Approving and Following Up an Appraisal (PA-PD).

Example No.1

<table>
<thead>
<tr>
<th>Form of appraisal</th>
<th>Appraisers</th>
<th>Appraisees</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personnel appraisal</td>
<td>Supervisors</td>
<td>Employees</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Possible Combinations</td>
</tr>
</tbody>
</table>

Appraisers Appraisees

<table>
<thead>
<tr>
<th>P</th>
<th>P</th>
</tr>
</thead>
<tbody>
<tr>
<td>US</td>
<td>P</td>
</tr>
</tbody>
</table>
The settings in the example above would result in the following:

- Appraisers and appraisees must be of the object type Person or User
- Object selection for appraisers and appraisees is restricted to objects of the object types Person and User
- In the appraisal, the appraisers are referred to as Supervisors, and the appraisees as Employees

**Note**
If you select the object type User, the system proposes the current user as the appraiser when you create an appraisal.

**'To-Do' Lists**
A 'to-do' list enables you to draw up a list of objects for which you need to prepare appraisals. You can decide whether you specify an object that you want to appraise, and then look for suitable appraisers, or whether you specify an appraiser, and look for objects to appraise.
For more information on 'to-do' lists, refer to the SAP Library (Human Resources -> Personnel Management -> Personnel Development -> Appraisal Systems -> Appraisal Creation -> Preparation of an Appraisal -> 'To-Do' List Creation).

**Activities**
1. Choose Edit -> New entries in the Change View "HR-PD Form of Appraisal": Overview screen.
   The New Entries: Overview of Added Entries screen appears.
2. In the Form of appraisal ID field, enter a unique numeric ID for the form of appraisal.
3. In the Form of appraisal field, enter a name for the form of appraisal.
4. In the Appraiser field, enter the name to be used for the appraisers on the appraisal (e.g. 'Supervisors').
5. In the Appraisee field, enter the name to be used for the appraisees (or appraised objects) on the appraisal (e.g. 'Employees').
6. Choose Enter.
7. Select the form of appraisal, and choose --Possible Combinations.
   The Change View "Possible Combinations (Form of Appraisal)" screen appears.
9. In the Appraiser field, enter the object types that are to be allowed as appraisers.
10. In the Appraisee field, enter the object types that are to be allowed as appraisees.
11. If required, specify an evaluation path or selection ID. Use the Evaluation path 1 or Selection ID 1 field to select appraisees for an appraiser, or the Evaluation path 2 or Selection ID 2 field to select appraisers for appraisees.
12. Choose Enter.
13. Save the form of appraisal.

**Edit Scales**
You define and change the proficiency scales that are used in the Qualifications and Requirements and Appraisal Systems components. You define a scale by specifying a unique numeric identifier and a name for the scale. You will also have to define proficiencies for each scale.
There are two basic types of scale:

- Quality scales
- Quantity scales

**Creating a quality scale**
1. Choose Quality scale.
   The Change View "Proficiencies on a Quality Scale": Overview screen appears.
2. Choose Edit -> New entries.
3. Enter your data as required.
**Note**
When you create and change quality scales, please ensure that you start numbering your proficiencies with 1 (or 0), and that your proficiencies are numbered consecutively without any gaps.
4. Choose ENTER.
5. Save the scale.

**Creating a quantity scale**
1. Choose Quantity scale.
   The Change View "Proficiencies on a Quantity Scale": Overview screen appears.
2. Choose Edit -> New entries.
3. The screen New Entries: Overview of Added Entries appears.
4. Enter your data as required.
5. Choose ENTER.
**Note**
If you entered the value 0 in the Lowest proficiency field, this is not displayed in change mode.
Save the scale.
Creating proficiency descriptions for quality scales

1. Select the scale in question.
2. In the structure on the left, choose Proficiencies.
The Change "Proficiencies" View: Overview screen appears.
3. Select the proficiency for which you want to define a description.
4. In the structure on the left, choose Proficiency descriptions.
The Change "Proficiency Descriptions" View: Overview screen appears.
5. Choose Edit -> New entries.
The New Entries: Overview of Added Entries screen appears.
6. In the column entitled Line, enter the proficiency description. If necessary, you can use several lines.
7. In the column entitled Seq. number, number the lines in ascending order from 1 to n.
8. Choose ENTER.
9. Save your entries.

Translating a scale/proficiencies(proficiency descriptions.

1. Go to the object in question, and select it.
2. Choose Edit -> Translation.
The Choose Languages dialog box appears.
3. Select the desired languages, and choose Continue.
The dialog box Texts in Other Languages appears.
4. Specify the corresponding translations in the Name of object column.
5. Choose Continue.
6. Save your translation.

Edit Appraisals Catalog

you define and edit appraisal models. The appraisal model catalog contains appraisal models that can be copied to create actual appraisals.

Note
For further information on the effects that appraisal model catalog settings can have on the appraisal creation process, please refer to the SAP Library (Human Resources -> Personnel Management -> Personnel Development -> Appraisal Systems).
The Appraisal Systems component enables you to map all kinds of analytical appraisal procedures in your system.

- An appraisal model is a collection of criteria or qualifications (and, possibly, criteria groups), and is copied to create an actual appraisal. The following information is stored at the appraisal model level:
  - Form of appraisal
  - Appraisal type
  - The type of numbering used for appraisal elements when an actual appraisal is generated (Standard, None, Other)
  - Layout (description, note lines and display as checkboxes) for displaying appraisals in HTML format.
    Note
    These settings do not apply to the conventional display of appraisals, nor do they affect the formatting options available for appraisal comparisons, lists, and so on, in any way!
  - Field for appraiser (only for anonymous individual appraisals) when carrying out appraisals in HTML format
  - Processing (follow-up activities, processing of subappraisals, and further processing of an appraisal)
  - The functions specified in the step Define Permissible Functions are the functions that are available for follow-up and further processing.
    Two function modules are provided which transfer the appraisal results to Compensation Management, and transfer the appraisal results of qualifications to the qualifications subprofile of the object to be appraised.
    Further processing of subappraisals only really applies to the appraisal type (anonymous) multisource appraisal. The following function modules are provided to automatically generate overall appraisals: Determine overall result by average and Transfer overall result from last subappraisal (takes the result of the last appraisal held - the appraisal by the employee's supervisor, for example - and uses this as the overall result).
    The further processing flag for appraisals determines which further processing options are allowed for archived (completed, rejected, approved) appraisals.
    Note
    Please bear the following point in mind if you want to use the follow-up processing workflow (WS 01000105):
    - The further processing modules that the workflow is to execute in follow-up processing must be selected for the corresponding appraisal models
    - It must be possible to reset the status to In process if necessary
For more information on the workflow, refer to the SAP Library (HR - Human Resources -> PA - Personnel Management -> Personnel Development -> Workflow Scenarios in Personnel Development (PA-PD) -> Approve and Follow Up Appraisal).

- Restriction to one appraisal per period to be appraised (see Flag: Only One Appraisal Allowed)
- Scale for results (quality scale - including proficiency 0, quantity scale)
- Input options for appraisal results (optional entry field, required entry field, no entries)
- Calculation methods for appraisal results (manual, total, average, percentage, user-specific)
- Whether notes can be stored

**Criteria groups** are used to structure appraisal models logically. The use of criteria groups is optional - they can only be assigned directly beneath the appraisal model and cannot contain further criteria groups. Criteria groups can be rated. The following information can be stored at the criteria group level:

- Scale for results (see above)
- Input options for results (see above)
- Calculation methods for results (see above)
- Whether notes can be stored

**Criteria** are the individual characteristics that are to be rated during the appraisal. A criterion can be assigned beneath either an appraisal model, a criteria group, or a qualification, but **not** beneath another criterion. The following information can be stored at the criterion level:

- Scale for results (see above)
- Input options for results (see above)
- Calculation methods for results (none, user-specific)
- Whether notes can be stored

Within a form of appraisal, you can use **qualifications** instead of criteria groups as appraisal elements (for possible structures, see below). You can use all the qualifications in the qualification catalog for this purpose. You can transfer the appraisal results for qualifications into the profile of the person appraised as a follow-up activity (see below). The following information is stored at the qualifications level:

- Scale for results (inherited from the qualification group - cannot be changed in the appraisals catalog)
- Input options for results (see above)
- Calculation methods for results
  The function module *Transfer Qualification Proficiency* is also available for qualifications - this module takes the proficiency from the qualifications profile of the appraisee.
- Whether notes can be stored

**Remember**:
- You can insert qualifications into an appraisal model only via the function *Insert existing appraisal element* (see below).
- You can process qualifications only in the qualifications catalog. (Exception: tab page *Result*; see below).
- The settings on the *Additional data* tab page are of no significance to the appraisal model.

**Caution**
In the following situations, you might encounter problems calculating results:

- If the Total, Average or Percentage calculation method has been selected for a criteria group or qualification, but this criteria group or qualification has no lower-level appraisal elements

- If the calculation method Other has been selected for an appraisal element, and the function module in question does not return a result. In both these cases, if you entered a rating manually, this rating will be overwritten by the value 0 when the appraisal results are recalculated.

You can nest the appraisal elements within an appraisal model as follows:

Appraisal model
Criterion
Qualification
Criteria group
Criterion
Qualification
You can specify a weighting and a sort sequence for every criterion and criteria group. On the Profiencies tab page, you can enter a user-definable text for the proficiencies of the scales used (applies only to quality scales). The proficiency descriptions of the scale in question are proposed as defaults (if there are any). You can overwrite these defaults as required.

In the case of qualifications, the proficiency descriptions of the corresponding qualification group are defaulted (if there are any); otherwise, the proficiency descriptions of the corresponding scale are defaulted (once again, if there are any). The proficiency descriptions of qualifications must be edited in the qualifications catalog.

A translation function is also available so that you can use the appraisal models in your catalog in various languages.

When you create catalog entries, you can either create brand new entries (appraisal models, criteria groups, criteria), or base them on an existing entry (criteria groups, criteria, and qualifications). If you select an existing entry, a new object is not created (instead, the existing object is used several times). This means that if you change its attributes, this will affect all occurrences of the object. You can find out where, and how often, an appraisal element is used by generating a where-used list.

**Note**

Appraisals can only be compared with each other if they share the same appraisal model, or if at least the first of their appraisal elements (as per the appraisal model) correspond. In the latter case, as many criteria groups and criteria as possible (and the sequence in which they appear) have to correspond so that the appraisals can be compared constructively and the results interpreted.

If a criterion is deleted from an appraisal model, it is displayed under the node Entries not used. To delete an entry entirely from the catalog, you must delete it once again from here.

**Caution** Please note the following when deleting objects from the appraisals catalog:

- If you delete a criterion from a criteria group that is used elsewhere, all occurrences of this criterion will be deleted (even where the criteria is used elsewhere)! For this reason, please always generate a where-used list before you delete a criterion!

- You can delete an appraisal element from the appraisals catalog only if you are no longer using it. If possible, please generate a where-used list using the reporting function for appraisals, and delete the appraisals first. If you do not select a scale for an appraisal element, you cannot specify a calculation method. This ensures that each result can be interpreted using the appropriate scale.

A preview function is available to let you view the layout of an actual appraisal. You can enter results and calculation methods in this preview. However, you cannot save the preview, or create any notes for it.

**Note**

If you set the flag Without note for an appraisal element, you cannot print any note lines on appraisal sheets.

**Note**

If you create an appraisal model with the appraisal type anonymous individual appraisal or anonymous multisource appraisal, please ensure that the role name in the form of appraisal does not reveal the identity of the appraiser.

**Example**

**Example of an appraisal model**

- Catalog
- Personnel appraisal (appraisal model)
- Work-related skills (criteria group)
- Quality of work (criterion)
- Ability to cope with stress (criterion)
- Specialist knowledge (criterion)
- Management skills (criteria group)
- Delegation (criterion)
- Objectivity (criterion)

**Example of an appraisal**

Your company wants to introduce annual personnel reviews. In each case, a supervisor is to appraise an employee. Further appraisal details include:

- Five criteria are to be rated. These 5 criteria are subdivided into 2 criteria groups.

- All appraisal elements are to be rated on a scale of 1 to 10, and every criterion must be given a rating.

- The average of the results of the criteria groups and the appraisal model is calculated; these results cannot be changed.

- Notes should be created for all appraisal elements.

- The various appraisal elements are to be numbered sequentially using Arabic numerals.

- All appraisal elements have the same weighting, and are sorted alphabetically. To do this, make the following settings for the appraisal elements in question:

**Appraisal model**

- Tab page

Object name: Personnel appraisal

Form of appraisal: Personnel appraisal (see step )
Appraisal type: Individual appraisal

- Tab page Additional data
  Numbering: Standard

- Tab page Result
  Scale: 10-points scale
  Input: No entry
  Calculation: Average

Criteria groups

- Tab page Criteria group
  Object name: e.g. Work-related skills

- Tab page Result
  Scale: 10-points scale
  Input: No entry
  Calculation: Average

Criteria

- Tab page Criterion
  Object name: e.g. Quality of work

- Tab page Result
  Scale: 10-points scale
  Input: Required entry
  Calculation: Manual

Example of preview of appraisal

<table>
<thead>
<tr>
<th>Name</th>
<th>Weighting</th>
<th>Rating</th>
<th>R.text</th>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personnel appraisal</td>
<td>1</td>
<td>$</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Work-related skills</td>
<td>1</td>
<td>$</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Quality of work</td>
<td>1</td>
<td>?</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Stress management</td>
<td>1</td>
<td>?</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Specialist knowledge</td>
<td>1</td>
<td>?</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Management skills</td>
<td>1</td>
<td>$</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Delegation</td>
<td>1</td>
<td>?</td>
<td>$</td>
<td>x</td>
</tr>
<tr>
<td>Objectivity</td>
<td>1</td>
<td>?</td>
<td>$</td>
<td>x</td>
</tr>
</tbody>
</table>

Legend
- Required entry, field is ready for input
- Result is calculated, field is not ready for input
- Field not ready for entry, to be filled automatically
- Note can be created

The proficiency descriptions are derived from the scale or qualification group. Further processing Deleting and resetting status to In process not allowed.

Sorting and weighting
Entries are sorted alphabetically

The weighting is 1. Standard further processing modules:

- Transfer qualifications
- Adjust remuneration

Note
You must define a matrix guideline if you want to use the 'Adjust remuneration' module. See Define Guidelines and Define Matrix Guidelines.

Standard modules for processing subappraisals:

- Determine overall result by average

Transfer overall result from last subappraisal Activities
Before you perform any of the following activities, you must specify a date as of which the changes are valid.
1. Choose Settings -> Set period... in the Catalog; Change Appraisal Model screen.
2. In the Key date field, enter a date, and choose Continue.

Note
The validity end date for the catalog is always 12/31/9999.
The Catalog: Change Appraisal Model screen appears.

Overview of the activities you can perform:

- Create new appraisal model
- Create new criteria group
- Insert existing appraisal element
- Change entry
- Translate entry
- Translate description
- Create/change proficiency descriptions for object
- Translate proficiency description
- Change weighting and sort sequence

Create new appraisal model

1. Position your cursor on the line Catalog.
2. Choose Entry -> Insert -> New appraisal element.

The Create Appraisal Model screen appears.
3. On the various tab pages, enter your data as required.
   Note
   On the Result tab page, select a scale and choose Enter. The Calculation box will then be ready for input.
4. Save the appraisal model.
5. If you want to create further appraisal models, choose Create new entry. Otherwise, choose Continue.

Create new criteria group

1. Position the cursor on an appraisal model.
2. Choose Entry -> Insert -> New appraisal element.

The Create dialog box appears.
3. Position your cursor on the line Criteria group, and choose Transfer.

The Create Criteria group dialog box appears.
4. On the various tab pages, enter your data as required.
   Note
   On the Result tab page, select a scale and choose Enter. The Calculation box will then be ready for input.
5. Save the criteria group.
6. If you want to create further criteria groups, choose Create new entry. Otherwise, choose Continue.

Create new criterion

1. Position the cursor on an appraisal model, a criteria group, or a qualification.
2. Choose Entry -> Insert -> New appraisal element.

The Create Criterion dialog box appears.
3. On the various tab pages, enter your data as required.
   Note
   On the Result tab page, select a scale and choose Enter. The Calculation box will then be ready for input.
4. Save the criterion.
5. If you want to create further criteria, choose Create new entry. Otherwise, choose Continue.

Insert existing appraisal element

1. Position your cursor on the appraisal model or criteria group beneath which you want to insert the existing entry.
2. Choose Entry -> Insert -> Existing appraisal element.

The Create dialog box appears.
3. Position your cursor on the appraisal element you want, and choose Transfer.

The Select Target Objects or Select Qualifications dialog box appears.
4. Select the entry you require, and choose Continue.

The Catalog: Change Appraisal Model screen appears again. The existing entry has been inserted. The attributes of this entry apply to all its occurrences.

Change entry

1. Position your cursor on the entry you want to change.
2. Choose Entry -> Choose.
The Change Entry dialog box appears.
3. Make your changes as required.

Note
If you change an appraisal element, the changes do not affect the appraisals that are in the preparation phase.
4. Save your changes.

Translate entry
1. Select the entries you want to translate.
2. Choose Entry -> Translate -> Text.
The Translation: Text dialog box appears.
3. Select one or more languages, and choose Transfer.
The Translation: Entry dialog box appears.
4. Select a target language.
5. Enter the translation in the Translation (<Target language>) column.
6. Save the translations.
7. Choose Continue.

Translate description
1. Select the entry whose description you want to translate.
2. Choose Entry -> Translate -> Description.
The Translation: Description dialog box appears.
3. Select a target language.
4. Enter the translation.
5. Save the translation.
6. Choose Continue.

Creating/Changing Proficiency Descriptions for an Object
1. Open up the entry in question by double-clicking it.
2. Choose the Proficiencies tab page.
In the standard system, the Default flag is activated. This means that any existing proficiency descriptions for the scale (or, in the case of qualifications, the qualification group, if applicable) are defaulted automatically.
3. To overwrite the defaults, deactivate the Default flag.

Note
If you change the defaulted proficiency descriptions for an object, you should always do this (from the object) for all of the proficiencies of the scale.
4. Select the proficiency for which you want to create a description.
5. Enter the description.
6. Save your changes.

Translate proficiency description
1. Select the entry whose proficiency description you want to translate.
2. Choose Entry -> Translate -> Proficiency Description.
The Translation: Description dialog box appears.
3. Select a target language.
4. Select the proficiency whose description you want to translate, and enter your translation.
5. Save the translations.
6. Repeat the procedure for further proficiencies.
7. Choose Continue.

Change sorting and weighting
1. Select an appraisal model, an appraisal group, or a qualification, and choose Entry -> Sorting and weighting.
The Change Sorting and Weighting dialog box appears.
2. In the relevant columns, change the sorting or weighting.
3. Save the changes.